summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoelacanthus2020-11-10 00:51:09 +0800
committerCoelacanthus2020-11-10 00:51:09 +0800
commit57919cfd2e87d5852fc47c2e55f38d7901d691cf (patch)
tree7acc7b7c8ea18f3c059bc0c5674d25a5eb592c84
downloadaur-57919cfd2e87d5852fc47c2e55f38d7901d691cf.tar.gz
init
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..991da4b1f1f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = fcitx5-theme-opensuse
+ pkgdesc = Fcitx5 theme on openSUSE, including Dartmouth, Harlequin, and New Air
+ pkgver = 0.0.0.20201110
+ pkgrel = 1
+ url = https://github.com/xuzhao9/fcitx5-theme-opensuse
+ arch = any
+ license = LGPL2.1
+ source = https://github.com/xuzhao9/fcitx5-theme-opensuse/archive/62ed596f9585344e95b6e05cbb750c7f622dd82a/fcitx5-theme-opensuse-62ed596f9585344e95b6e05cbb750c7f622dd82a.tar.gz
+ b2sums = 1d41830e720293e033085e08f6f8d4c21cf04604094d414e74909ad5e7395a4afa06d81f70d8447164c0dead89a9f184606cca21832fb1887eb4a1f356ca6768
+
+pkgname = fcitx5-theme-opensuse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36fc870e977d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Coelacanthus <liuhongwu2003@outlook.com>
+
+pkgname=fcitx5-theme-opensuse
+_pkgname=fcitx5-theme-opensuse
+pkgver=0.0.0.20201110
+_commit=62ed596f9585344e95b6e05cbb750c7f622dd82a
+pkgrel=1
+pkgdesc="Fcitx5 theme on openSUSE, including Dartmouth, Harlequin, and New Air "
+arch=('any')
+url="https://github.com/xuzhao9/fcitx5-theme-opensuse"
+license=('LGPL2.1')
+source=("https://github.com/xuzhao9/fcitx5-theme-opensuse/archive/$_commit/$_pkgname-$_commit.tar.gz")
+b2sums=('1d41830e720293e033085e08f6f8d4c21cf04604094d414e74909ad5e7395a4afa06d81f70d8447164c0dead89a9f184606cca21832fb1887eb4a1f356ca6768')
+
+package() {
+ cd $_pkgname-$_commit
+ _variant_names=('Dartmouth' 'Harlequin' 'NewAir')
+ for _variant_name in "${_variant_names[@]}"
+ do
+ install -Dm644 $_variant_name/highlight.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/highlight.png
+ install -Dm644 $_variant_name/bar.png "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/bar.png
+ install -Dm644 $_variant_name/theme.conf "$pkgdir"/usr/share/fcitx5/themes/$_variant_name/theme.conf
+ done
+
+ #install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}