summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorakku2023-10-18 20:14:48 +0900
committerakku2023-10-18 20:14:48 +0900
commit6e78e8127cb7fc007774bc63b5acb5c9bb8f88a6 (patch)
treecb2596bbb0be3ca53fbb35bbcf9edd1af67e8b17
downloadaur-6e78e8127cb7fc007774bc63b5acb5c9bb8f88a6.tar.gz
First
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3f10f1b6537
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fcitx5-tmux-git
+ pkgdesc = Tmux plugin to make tmux as a fcitx 5 client
+ pkgver = r5.35daf5d
+ pkgrel = 1
+ url = https://github.com/wengxt/fcitx5-tmux
+ arch = any
+ license = GPLv2
+ makedepends = git
+ makedepends = cmake
+ depends = dbus
+ depends = fcitx5
+ depends = tmux
+ source = fcitx-tmux5-git::git+https://github.com/wengxt/fcitx5-tmux.git
+ md5sums = SKIP
+
+pkgname = fcitx5-tmux-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d470345f0fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: akku <akku[at]mirai[dot]re>
+pkgname=fcitx5-tmux-git
+# Because the developer has not set the version.
+pkgver=r5.35daf5d
+pkgrel=1
+pkgdesc="Tmux plugin to make tmux as a fcitx 5 client"
+arch=('any')
+url="https://github.com/wengxt/fcitx5-tmux"
+license=('GPLv2')
+depends=('dbus' 'fcitx5' 'tmux')
+makedepends=('git' 'cmake')
+source=("${pkgname}"::'git+https://github.com/wengxt/fcitx5-tmux.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib/fcitx5-tmux
+ cmake --build .
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ DESTDIR=${pkgdir} cmake --install .
+}