summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-02-20 05:13:22 -0500
committeracxz2020-02-20 05:13:22 -0500
commitb5420a921e499c8122ecbe5c0deefa41139a196a (patch)
tree5d689fc25497eebb73723d4361d192f9d1482e97
parentd3b77c7e5e33fc4e72b7352101aafa769105fc3d (diff)
downloadaur-b5420a921e499c8122ecbe5c0deefa41139a196a.tar.gz
upgpkg: fcl 0.6.0-1
upstream release updpkg 0.6.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 077986159356..eaeb6c16994c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = fcl
pkgdesc = Flexible Collision Library.
- pkgver = 0.5.0
- pkgrel = 2
- url = https://github.com/flexible-collision-library
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/flexible-collision-library/fcl
arch = i686
arch = x86_64
license = BSD
makedepends = cmake
makedepends = octomap
- depends = boost
depends = libccd
+ depends = eigen
optdepends = octomap: collision detection with octrees
optdepends = tinyxml: support for global penetration depth test
optdepends = flann: support for fast approximate nearest neighbor searches
- source = https://github.com/flexible-collision-library/fcl/archive/0.5.0.tar.gz
- sha256sums = 8e6c19720e77024c1fbff5a912d81e8f28004208864607447bc90a31f18fb41a
+ source = https://github.com/flexible-collision-library/fcl/archive/v0.6.0.tar.gz
+ sha256sums = 6891abac5cc26d64f5ef8894bc6c2a30174558c5c83a3ed63cf65a21cb619b2b
pkgname = fcl
diff --git a/PKGBUILD b/PKGBUILD
index 97110a13711d..1d1e99b00603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
# Contributor: Benjamin Chretien <chretien at lirmm dot fr>
pkgdesc="Flexible Collision Library."
-url='https://github.com/flexible-collision-library'
+url='https://github.com/flexible-collision-library/fcl'
pkgname=fcl
-pkgver=0.5.0
+pkgver=0.6.0
arch=('i686' 'x86_64')
-pkgrel=2
+pkgrel=1
license=('BSD')
makedepends=('cmake' 'octomap')
-depends=('boost' 'libccd')
+depends=('libccd' 'eigen')
optdepends=('octomap: collision detection with octrees'
'tinyxml: support for global penetration depth test'
'flann: support for fast approximate nearest neighbor searches')
_dir=fcl-${pkgver}
-source=(https://github.com/flexible-collision-library/fcl/archive/${pkgver}.tar.gz)
-sha256sums=('8e6c19720e77024c1fbff5a912d81e8f28004208864607447bc90a31f18fb41a')
+source=(https://github.com/flexible-collision-library/fcl/archive/v${pkgver}.tar.gz)
+sha256sums=('6891abac5cc26d64f5ef8894bc6c2a30174558c5c83a3ed63cf65a21cb619b2b')
build() {
mkdir -p ${srcdir}/build