summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2013-10-28 16:11:36 +0100
committerBenjamin Chrétien2013-10-28 16:12:16 +0100
commitcc749b2ed39de116956f03f271d2af13a5d0b1ca (patch)
tree0c6f446d5d964b3b9f117a8dc23867b86fe4f508
downloadaur-cc749b2ed39de116956f03f271d2af13a5d0b1ca.tar.gz
Add fcl and libccd packages.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14727419fff2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fcl
+ pkgdesc = Flexible Collision Library.
+ pkgver = 0.2.9
+ pkgrel = 1
+ url = https://github.com/flexible-collision-library
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = boost
+ depends = libccd
+ optdepends = octomap: collision detection with octrees
+ optdepends = tinyxml: support for global penetration depth test
+ optdepends = flann: support for fast approximate nearest neighbor searches
+ source = https://github.com/flexible-collision-library/fcl/archive/0.2.9.tar.gz
+ md5sums = SKIP
+
+pkgname = fcl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80a831d13bde
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+#Maintainer: Benjamin Chretien <chretien at lirmm dot fr>
+pkgdesc="Flexible Collision Library."
+url='https://github.com/flexible-collision-library'
+pkgname=fcl
+pkgver=0.2.9
+arch=('i686' 'x86_64')
+pkgrel=1
+license=('BSD')
+makedepends=('cmake')
+depends=('boost' 'libccd')
+optdepends=('octomap: collision detection with octrees'
+ 'tinyxml: support for global penetration depth test'
+ 'flann: support for fast approximate nearest neighbor searches')
+_dir=fcl-${pkgver}
+source=(https://github.com/flexible-collision-library/fcl/archive/${pkgver}.tar.gz)
+md5sums=('SKIP')
+
+build() {
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+ cmake ${srcdir}/${_dir} -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+#check() {
+# cd "${srcdir}/build/test"
+# make test
+#}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}