summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-19 13:57:38 +0200
committerBenjamin Chrétien2014-06-19 13:57:38 +0200
commitfb63b585c0834b41e0be7014b5f4aebbcf73a21d (patch)
tree46991041052dc0fb8ff3573afbc0b29f1e660d7d
parentcc749b2ed39de116956f03f271d2af13a5d0b1ca (diff)
downloadaur-fb63b585c0834b41e0be7014b5f4aebbcf73a21d.tar.gz
libdart, fcl, ccd updates.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14727419fff2..5d13c7509b7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fcl
pkgdesc = Flexible Collision Library.
- pkgver = 0.2.9
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/flexible-collision-library
arch = i686
@@ -12,8 +12,8 @@ pkgbase = fcl
optdepends = octomap: collision detection with octrees
optdepends = tinyxml: support for global penetration depth test
optdepends = flann: support for fast approximate nearest neighbor searches
- source = https://github.com/flexible-collision-library/fcl/archive/0.2.9.tar.gz
- md5sums = SKIP
+ source = https://github.com/flexible-collision-library/fcl/archive/0.3.1.tar.gz
+ md5sums = 2f3c6f45a2eb482e4f2cddb4cfa4aba0
pkgname = fcl
diff --git a/PKGBUILD b/PKGBUILD
index 80a831d13bde..2ee540754e9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,28 @@
pkgdesc="Flexible Collision Library."
url='https://github.com/flexible-collision-library'
pkgname=fcl
-pkgver=0.2.9
+pkgver=0.3.1
arch=('i686' 'x86_64')
pkgrel=1
license=('BSD')
makedepends=('cmake')
depends=('boost' 'libccd')
optdepends=('octomap: collision detection with octrees'
- 'tinyxml: support for global penetration depth test'
- 'flann: support for fast approximate nearest neighbor searches')
+'tinyxml: support for global penetration depth test'
+'flann: support for fast approximate nearest neighbor searches')
_dir=fcl-${pkgver}
source=(https://github.com/flexible-collision-library/fcl/archive/${pkgver}.tar.gz)
-md5sums=('SKIP')
+md5sums=('2f3c6f45a2eb482e4f2cddb4cfa4aba0')
build() {
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
- cmake ${srcdir}/${_dir} -DCMAKE_INSTALL_PREFIX=/usr
- make
+ rm -rf ${srcdir}/build && mkdir -p ${srcdir}/build
+ cd ${srcdir}/build
+
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+
+ make
}
#check() {
@@ -28,6 +32,7 @@ build() {
#}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+
+ make DESTDIR="${pkgdir}/" install
}