summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAurélien Grosdidier2020-09-14 20:44:40 +0200
committerAurélien Grosdidier2020-09-14 20:47:23 +0200
commitafb1b0f27c0c043bb4683b10a1642e587baecd17 (patch)
treeb0168dc613faf58e57c30c4fe7827a7ccf4cdfd9
downloadaur-afb1b0f27c0c043bb4683b10a1642e587baecd17.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15f0943a2ed6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fclones-git
+ pkgdesc = Efficient Duplicate File Finder
+ pkgver = v0.8.0
+ pkgrel = 1
+ url = https://github.com/pkolaczk/fclones
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ provides = fclones
+ conflicts = fclones
+ source = git+https://github.com/pkolaczk/fclones
+ md5sums = SKIP
+
+pkgname = fclones-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..737c0f8bb707
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: aurelien.grosdidier+archlinux@gmail.com
+_pkgname=fclones
+pkgname=${_pkgname}-git
+pkgver=v0.8.0
+pkgrel=1
+pkgdesc='Efficient Duplicate File Finder'
+arch=('i686' 'x86_64')
+url="https://github.com/pkolaczk/fclones"
+license=('MIT')
+depends=()
+makedepends=('rust' 'cargo' 'git')
+provides=('fclones')
+conflicts=('fclones')
+source=("git+https://github.com/pkolaczk/fclones")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/$_pkgname" \
+ && cargo build --release
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm755 "target/release/fclones" "$pkgdir/usr/bin/fclones"
+}