summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiri Pospisil2023-06-27 17:59:58 +0000
committerJiri Pospisil2023-06-27 17:59:58 +0000
commit2a62a7a1ddaa27f27e70060f4b7d39032da148b7 (patch)
tree4491333b45533333647b30193de92b5a0516afa2
downloadaur-2a62a7a1ddaa27f27e70060f4b7d39032da148b7.tar.gz
Initial upload, version 0.2.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD36
-rw-r--r--icon.pngbin0 -> 25365 bytes
5 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c02b0bd04577
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fclones-gui
+ pkgdesc = Interactive duplicate file finder and remover
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/pkolaczk/fclones-gui
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = gendesk
+ depends = gtk4
+ depends = libadwaita
+ source = https://github.com/pkolaczk/fclones-gui/archive/refs/tags/v0.2.0.tar.gz
+ source = icon.png
+ b2sums = defc9bdbcf9954094593b0841db08276370d205d72c63d995cca0bfd613606b51e30d6198c690e2d0fd971a23a0ebb6993f8acd783ce8b2d50281c8e5c8cca7a
+ b2sums = bc3f8685c7e0d35fe409416d9cf1b6cf381058cf3866ffb16a0ccb3a4527045bf9fa3cf4eee6e8644cb4894da8db6fbb2a991824356e61d13c12ba3b5f4d4c38
+
+pkgname = fclones-gui
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a412854c0b53
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.*
+src/
+pkg/
+fclones-gui.desktop
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..aa1c2cb10374
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2020 Piotr Kołaczkowski
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9ae1a55b977
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jiri Pospisil <jiri@jpospisil.com>
+pkgname=fclones-gui
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Interactive duplicate file finder and remover'
+url='https://github.com/pkolaczk/fclones-gui'
+arch=('x86_64')
+makedepends=('cargo' 'gendesk')
+depends=('gtk4' 'libadwaita')
+license=('MIT')
+source=(
+ "https://github.com/pkolaczk/fclones-gui/archive/refs/tags/v$pkgver.tar.gz"
+ 'icon.png')
+b2sums=('defc9bdbcf9954094593b0841db08276370d205d72c63d995cca0bfd613606b51e30d6198c690e2d0fd971a23a0ebb6993f8acd783ce8b2d50281c8e5c8cca7a'
+ 'bc3f8685c7e0d35fe409416d9cf1b6cf381058cf3866ffb16a0ccb3a4527045bf9fa3cf4eee6e8644cb4894da8db6fbb2a991824356e61d13c12ba3b5f4d4c38')
+
+prepare() {
+ gendesk -n -f --pkgname "$pkgname" --pkgdesc "$pkgdesc" --name FClones --categories Utility
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+package() {
+ install -Dm644 ../icon.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 target/release/fclones-gui "$pkgdir/usr/bin/fclones-gui"
+}
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..90c32b0e2963
--- /dev/null
+++ b/icon.png
Binary files differ