summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2015-06-09 09:20:10 +1000
committerXavion2015-06-09 09:54:22 +1000
commit2f32a2a018c838b8593ff5bbb03525bcce0412d8 (patch)
treeed950718d969d6339a2a79792570081194f76aaa
downloadaur-2f32a2a018c838b8593ff5bbb03525bcce0412d8.tar.gz
Initial AUR v4 importation
modified: PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--FcronQ.install49
-rw-r--r--PKGBUILD37
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61655a9aecd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fcronq
+ pkgdesc = An Fcron GUI
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = http://FcronQ.Xavion.name
+ install = FcronQ.install
+ arch = any
+ license = GPL3
+ depends = pyqt
+ depends = fcron
+ optdepends = gksu: A SU(do) GUI
+ optdepends = terminal: A shell GUI
+ source = http://prdownloads.sourceforge.net/fcronq/FcronQ-0.4.2.tar.bz2
+ sha1sums = 6157b70d484a95944c560f14638c07b88e01a2c3
+
+pkgname = fcronq
+
diff --git a/FcronQ.install b/FcronQ.install
new file mode 100644
index 000000000000..28dd98849429
--- /dev/null
+++ b/FcronQ.install
@@ -0,0 +1,49 @@
+# FcronQ: Installer: Arch
+# Contributor: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+post_install() {
+ # Change file permissions
+ chmod 777 /usr/share/FcronQ/Source/
+ chmod 644 /etc/fcron/fcron.conf
+
+ # Remove old files
+ user_remove
+
+ #/bin/true
+}
+
+post_upgrade() {
+ post_install
+ #/bin/true
+}
+
+pre_remove() {
+ /bin/true
+}
+
+user_remove() {
+ # User
+ if [ ${USER} ]; then
+ export USER=${LOGNAME}
+ fi
+
+ # Home
+ if [ ${SUDO_USER} ]; then
+ export HOME=/home/${SUDO_USER}
+ else
+ export HOME=/home/${USER}
+ fi
+}
+
+post_remove() {
+ rm -rf /usr/share/FcronQ/
+
+ user_remove
+
+ #/bin/true
+}
+
+op=$1
+shift
+
+$op "$@"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6de8962fe83d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+pkgname=fcronq
+_filename_=FcronQ
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="An Fcron GUI"
+arch=("any")
+url="http://${_filename_}.Xavion.name"
+license=("GPL3")
+depends=("pyqt" "fcron")
+optdepends=("gksu: A SU(do) GUI"
+ "terminal: A shell GUI")
+install="${_filename_}.install"
+source=(http://prdownloads.sourceforge.net/${pkgname}/${_filename_}-${pkgver}.tar.bz2)
+
+build() {
+ cd "${srcdir}"/${_filename_}/Build
+
+ # Fixes
+ sed -i "s|slCmdArgs.append(\"'\" + Settings.Status.sScript + \"'\")|slCmdArgs.append(Settings.Status.sScript)|g" ../Source/Thread.py
+
+ #make uninstall
+ #make clean
+ make
+}
+
+package() {
+ cd "${srcdir}"/${_filename_}/Build
+
+ make DESTDIR="${pkgdir}" install
+
+ # Messages
+ msg "Seek further information or send feedback via the 'Help' menu."
+}
+
+sha1sums=('6157b70d484a95944c560f14638c07b88e01a2c3')