summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-10-30 10:42:56 -0500
committerDan Beste2017-10-30 10:42:56 -0500
commit18cb7d4b5274614f0ebd47207152aa7ab5d3f05b (patch)
tree879bb741eb1bea48c25a5129affe0b436d6915ff
downloadaur-18cb7d4b5274614f0ebd47207152aa7ab5d3f05b.tar.gz
Init
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD40
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3eaf78e43493
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fd-git
+ pkgdesc = A simple, fast and user-friendly alternative to find.
+ pkgver = 5.0.0.r3.gc022528
+ pkgrel = 1
+ url = https://github.com/sharkdp/fd
+ arch = i686
+ arch = x86_64
+ license = APACHE
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ makedepends = rust
+ provides = fd
+ conflicts = fd
+ source = fd-git::git+https://github.com/sharkdp/fd.git
+ sha256sums = SKIP
+
+pkgname = fd-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bc9028b62ecb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Blacklist:
+*
+
+# Whitelist:
+!.SRCINFO
+!.gitignore
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10d0c4de4f4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Dan Beste <dan.ray.beste@gmail.com>
+
+pkgname='fd-git'
+pkgver=5.0.0.r3.gc022528
+pkgrel=1
+pkgdesc='A simple, fast and user-friendly alternative to find.'
+arch=('i686' 'x86_64')
+url='https://github.com/sharkdp/fd'
+license=('APACHE' 'MIT')
+makedepends=('cargo' 'git' 'rust')
+provides=("${pkgname/-git}")
+conflicts=("${pkgname/-git}")
+source=("${pkgname}::git+https://github.com/sharkdp/fd.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+
+ git describe --long --tags \
+ | sed 's/v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+
+ cargo build --release
+}
+
+package() {
+ cd "${pkgname}"
+
+ install -m 755 \
+ -D "target/release/${pkgname/-git}" "${pkgdir}/usr/bin/${pkgname/-git}"
+ install -m 644 \
+ -D LICENSE-APACHE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-APACHE"
+ install -m 644 \
+ -D LICENSE-MIT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-MIT"
+}
+
+# vim: ts=2 sw=2 et: