summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-26 19:00:34 -0500
committerLuis Martinez2021-08-26 19:00:34 -0500
commitcd759eb3a9eeb4d314a804d9089f1557713d9391 (patch)
tree1cc1abb1e2934472afac08df07049f15a93424ed
parent6feeb93ed0b1080657cbdd020e0d61814b4ec721 (diff)
downloadaur-cd759eb3a9eeb4d314a804d9089f1557713d9391.tar.gz
update in accordance to updated Rust packaging guidelines
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD48
2 files changed, 32 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ede82d48809..bafeb02d922e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fd-git
pkgdesc = A simple, fast and user-friendly alternative to find.
- pkgver = 8.1.1.r20.g24402dd
+ pkgver = 8.2.0.r92.g3ba90dd
pkgrel = 1
url = https://github.com/sharkdp/fd
arch = i686
@@ -8,11 +8,11 @@ pkgbase = fd-git
license = APACHE
license = MIT
makedepends = git
- makedepends = rust
+ makedepends = cargo
+ depends = gcc-libs
provides = fd
conflicts = fd
- source = fd-git::git+https://github.com/sharkdp/fd.git
+ source = fd-git::git+https://github.com/sharkdp/fd
sha256sums = SKIP
pkgname = fd-git
-
diff --git a/PKGBUILD b/PKGBUILD
index fb44308b698f..f025af90a684 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,53 @@
-# Maintainer: lmartinez-mirror <lmartinez-mirror at no-reply dot github dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Kaare Jenssen <kaare at jenssen dot it>
# Contributor: Dan Beste <dan.ray.beste@gmail.com>
-pkgname='fd-git'
-pkgver=8.1.1.r20.g24402dd
+pkgname=fd-git
+pkgver=8.2.0.r92.g3ba90dd
pkgrel=1
pkgdesc='A simple, fast and user-friendly alternative to find.'
arch=('i686' 'x86_64')
url='https://github.com/sharkdp/fd'
license=('APACHE' 'MIT')
-makedepends=('git' 'rust')
+depends=('gcc-libs')
+makedepends=('git' 'cargo')
provides=('fd')
conflicts=('fd')
-source=($pkgname::git+https://github.com/sharkdp/fd.git)
+source=("$pkgname::git+$url")
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- git describe --long --tags | sed 's/v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git -C "$pkgname" describe --long --tags | sed 's/v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$pkgname"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
- cd $pkgname
- cargo build --release --locked
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+
+ cd "$pkgname"
+ cargo build --release --frozen --all-features
}
check() {
- cd $pkgname
- cargo test --release --locked
+ export RUSTUP_TOOLCHAIN=stable
+
+ cd "$pkgname"
+ cargo test --frozen --all-features
}
package() {
- cd $pkgname
- install -Dm755 target/release/fd "$pkgdir"/usr/bin/fd
- install -Dm644 target/release/build/fd-find-*/out/fd.bash "$pkgdir"/usr/share/bash-completion/completions/fd
- install -Dm644 target/release/build/fd-find-*/out/fd.fish "$pkgdir"/usr/share/fish/vendor_completions.d/fd.fish
- # Zsh script no longer exists in repo
- # install -Dm644 target/release/build/fd-find-*/out/_fd "$pkgdir"/usr/share/zsh/site-functions/_fd
- install -Dm644 doc/fd.1 "$pkgdir"/usr/share/man/man1/fd.1
- install -Dm644 LICENSE-APACHE "$pkgdir"/usr/share/licenses/fd/LICENSE-APACHE
- install -Dm644 LICENSE-MIT "$pkgdir"/usr/share/licenses/fd/LICENSE-MIT
+ cd "$pkgname"
+ install -Dm755 target/release/fd -t "$pkgdir/usr/bin/"
+ install -Dm644 target/release/build/fd-find-*/out/fd.bash "$pkgdir/usr/share/bash-completion/completions/fd"
+ install -Dm644 target/release/build/fd-find-*/out/fd.fish -t "$pkgdir/usr/share/fish/vendor_completions.d/"
+ install -Dm644 contrib/completion/_fd -t "$pkgdir/usr/share/zsh/site-functions/"
+ install -Dm644 doc/fd.1 -t "$pkgdir/usr/share/man/man1/"
+ install -Dm644 LICENSE-{APACHE,MIT} -t "$pkgdir/usr/share/licenses/$pkgname/"
}
# vim:set ts=2 sw=2 et: