summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-09 13:38:45 +0800
committerzxp198210052023-11-09 13:38:45 +0800
commit3a464f5060e9146dca7e6d006d9071540adf636c (patch)
tree31f616bd1e55ac1af6088bb5bfd0968e99d249d2
parent93e78b1621fb486dcf3c161d3ec3a15f6a17ec21 (diff)
downloadaur-3a464f5060e9146dca7e6d006d9071540adf636c.tar.gz
fix errors
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
-rw-r--r--fdc3-sail.sh5
3 files changed, 35 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f95ebffd443..0022c0c572cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
pkgbase = fdc3-sail-bin
pkgdesc = Open implementation of the FDC3 standard using Electron and an integrated App Directory.
pkgver = 22.12.6_1030
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/finos/FDC3-Sail
arch = x86_64
license = Apache
- depends = bash
+ makedepends = squashfuse
depends = electron24
depends = hicolor-icon-theme
+ depends = libx11
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = libdbusmenu-glib
+ depends = gtk2
+ depends = dbus-glib
provides = fdc3-sail=22.12.6_1030
conflicts = fdc3-sail
source = fdc3-sail-22.12.6_1030.AppImage::https://github.com/finos/FDC3-Sail/releases/download/v22.12.6-1030/FDC3-Sail-22.12.6-1030.AppImage
source = fdc3-sail.sh
sha256sums = 81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97
- sha256sums = 8de54674265f1c1b58fad8c858b1b9d10aa91fdfcb7cd498f7548cf49d26559b
+ sha256sums = f690d7b37c9817870fdeeb1898c6a2dcf9e081bec4e0bab9f40ea2b9636222ed
pkgname = fdc3-sail-bin
diff --git a/PKGBUILD b/PKGBUILD
index a8a3cce4d640..b73acb83e3df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,41 @@
pkgname=fdc3-sail-bin
_pkgname=FDC3-Sail
pkgver=22.12.6_1030
-pkgrel=3
+pkgrel=4
pkgdesc="Open implementation of the FDC3 standard using Electron and an integrated App Directory."
arch=('x86_64')
url="https://github.com/finos/FDC3-Sail"
license=('Apache')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
-depends=('bash' 'electron24' 'hicolor-icon-theme')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver//_/-}/${_pkgname}-${pkgver//_/-}.AppImage"
- "${pkgname%-bin}.sh")
+depends=(
+ 'electron24'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'gdk-pixbuf2'
+ 'libxext'
+ 'libdbusmenu-glib'
+ 'gtk2'
+ 'dbus-glib'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver//_/-}/${_pkgname}-${pkgver//_/-}.AppImage"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97'
- '8de54674265f1c1b58fad8c858b1b9d10aa91fdfcb7cd498f7548cf49d26559b')
-prepare() {
+ 'f690d7b37c9817870fdeeb1898c6a2dcf9e081bec4e0bab9f40ea2b9636222ed')
+build() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
diff --git a/fdc3-sail.sh b/fdc3-sail.sh
index aab90d794f9e..a9b56b8f9df9 100644
--- a/fdc3-sail.sh
+++ b/fdc3-sail.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron24
-_ASAR="/opt/fdc3-sail/fdc3-sail.asar"
+APPDIR=/usr/lib/fdc3-sail
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else