summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-03 16:40:46 +0800
committerzxp198210052023-08-03 16:40:46 +0800
commit5141f80b7460693cd696eded0308de417e03ae08 (patch)
tree58720c6809a653d936c346a279949a31f156f2d3
parent68787644bf3b030e916269c80cc6ff0b566f6713 (diff)
downloadaur-5141f80b7460693cd696eded0308de417e03ae08.tar.gz
optimized PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--fdc3-sail.sh6
3 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62e6e1dd92d1..65c5b2ee40b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = fdc3-sail-bin
pkgdesc = Open implementation of the FDC3 standard using Electron and an integrated App Directory.
- pkgver = 22.12.6.1030
- pkgrel = 1
+ pkgver = 22.12.6_1030
+ pkgrel = 2
url = https://github.com/finos/FDC3-Sail
arch = x86_64
license = Apache
+ depends = bash
depends = electron24
depends = hicolor-icon-theme
conflicts = fdc3-sail
- source = fdc3-sail-22.12.6.1030.AppImage::https://github.com/finos/FDC3-Sail/releases/download/v22.12.6-1030/FDC3-Sail-22.12.6-1030.AppImage
+ source = fdc3-sail-22.12.6_1030.AppImage::https://github.com/finos/FDC3-Sail/releases/download/v22.12.6-1030/FDC3-Sail-22.12.6-1030.AppImage
source = fdc3-sail.sh
sha256sums = 81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97
- sha256sums = fdc1caaf3e4f54c9a4dd60923e35e521a31884ae39b2dd0291b85baaba899ff7
+ sha256sums = 8de54674265f1c1b58fad8c858b1b9d10aa91fdfcb7cd498f7548cf49d26559b
pkgname = fdc3-sail-bin
diff --git a/PKGBUILD b/PKGBUILD
index a5f66acb1ad0..53d6bdf636df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="fdc3-sail-bin"
-pkgver=22.12.6.1030
-_appver=22.12.6-1030
-pkgrel=1
+pkgname=fdc3-sail-bin
+pkgver=22.12.6_1030
+pkgrel=2
pkgdesc="Open implementation of the FDC3 standard using Electron and an integrated App Directory."
arch=('x86_64')
url="https://github.com/finos/FDC3-Sail"
license=('Apache')
conflicts=("${pkgname%-bin}")
-depends=('electron24' 'hicolor-icon-theme')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${_appver}/FDC3-Sail-${_appver}.AppImage"
+depends=('bash' 'electron24' 'hicolor-icon-theme')
+source=("${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver//_/-}/FDC3-Sail-${pkgver//_/-}.AppImage"
"${pkgname%-bin}.sh")
sha256sums=('81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97'
- 'fdc1caaf3e4f54c9a4dd60923e35e521a31884ae39b2dd0291b85baaba899ff7')
+ '8de54674265f1c1b58fad8c858b1b9d10aa91fdfcb7cd498f7548cf49d26559b')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/fdc3-sail.sh b/fdc3-sail.sh
index a7b574433f2d..aab90d794f9e 100644
--- a/fdc3-sail.sh
+++ b/fdc3-sail.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron24
+_ASAR="/opt/fdc3-sail/fdc3-sail.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron24 /opt/fdc3-sail/fdc3-sail.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron24 --no-sandbox /opt/fdc3-sail/fdc3-sail.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file