summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-14 12:34:44 +0800
committerzxp198210052023-12-14 12:34:44 +0800
commit909664b302586e8b11dcc5d721c1296fae15ce71 (patch)
tree8d65735510304f19df9b19878f46cf69ea960db1
parent3a464f5060e9146dca7e6d006d9071540adf636c (diff)
downloadaur-909664b302586e8b11dcc5d721c1296fae15ce71.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--fdc3-sail.sh17
3 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0022c0c572cd..acbab083791e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fdc3-sail-bin
pkgdesc = Open implementation of the FDC3 standard using Electron and an integrated App Directory.
pkgver = 22.12.6_1030
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/finos/FDC3-Sail
arch = x86_64
license = Apache
@@ -19,6 +19,6 @@ pkgbase = fdc3-sail-bin
source = fdc3-sail-22.12.6_1030.AppImage::https://github.com/finos/FDC3-Sail/releases/download/v22.12.6-1030/FDC3-Sail-22.12.6-1030.AppImage
source = fdc3-sail.sh
sha256sums = 81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97
- sha256sums = f690d7b37c9817870fdeeb1898c6a2dcf9e081bec4e0bab9f40ea2b9636222ed
+ sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
pkgname = fdc3-sail-bin
diff --git a/PKGBUILD b/PKGBUILD
index b73acb83e3df..d1e9914679b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=fdc3-sail-bin
_pkgname=FDC3-Sail
pkgver=22.12.6_1030
-pkgrel=4
+_electronversion=24
+pkgrel=5
pkgdesc="Open implementation of the FDC3 standard using Electron and an integrated App Directory."
arch=('x86_64')
url="https://github.com/finos/FDC3-Sail"
@@ -10,7 +11,7 @@ license=('Apache')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
- 'electron24'
+ "electron${_electronversion}"
'hicolor-icon-theme'
'libx11'
'gdk-pixbuf2'
@@ -27,8 +28,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('81243023ba6af8562e5244f6d48f2e4dd8f17ab77984dda7a55ad0863959ea97'
- 'f690d7b37c9817870fdeeb1898c6a2dcf9e081bec4e0bab9f40ea2b9636222ed')
+ '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
diff --git a/fdc3-sail.sh b/fdc3-sail.sh
index a9b56b8f9df9..2ec4412e5c4f 100644
--- a/fdc3-sail.sh
+++ b/fdc3-sail.sh
@@ -1,11 +1,14 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron24
-APPDIR=/usr/lib/fdc3-sail
-export PATH="${APPDIR}:${PATH}"
-export LD_LIBRARY_PATH="${APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+set -e
+_APPDIR="/usr/lib/@appname@"
+export PATH="${_APPDIR}:${PATH}"
+export ELECTRON_IS_DEV=0
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+_ASAR="${_APPDIR}/@appasar@"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
fi \ No newline at end of file