summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Johnson2018-06-09 17:41:51 -0400
committerTyler Johnson2018-06-09 17:41:51 -0400
commit67000c2ae17bd3c6d3f1d5dc87d1095ebfa23ecb (patch)
tree325f86f861cd48de1c60ff285547ee651ba15d1f
downloadaur-67000c2ae17bd3c6d3f1d5dc87d1095ebfa23ecb.tar.gz
1.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD41
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0ae7ba4fa01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fdic
+ pkgdesc = Dictionary filter for STDIN
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/tejohnso/dictionary-filter
+ arch = x86_64
+ license = GPL
+ depends = gcc-libs
+ source = https://github.com/tejohnso/dictionary-filter/archive/1.0.0.tar.gz
+ md5sums = SKIP
+
+pkgname = fdic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2bed785a7f61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Tyler Johnson <mail@tyler-johnson.ca>
+pkgname=fdic
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="Dictionary filter for STDIN"
+arch=('x86_64')
+_reponame="dictionary-filter"
+url="https://github.com/tejohnso/$_reponame"
+license=('GPL')
+groups=()
+depends=('gcc-libs')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/tejohnso/dictionary-filter/archive/$pkgver.tar.gz")
+md5sums=("SKIP")
+noextract=()
+
+build() {
+ cd "$_reponame-$pkgver"
+ g++ -Wall -o fdic fdic.cpp dictionary.cpp
+}
+
+check() {
+ cd "$_reponame-$pkgver"
+ file -E fdic
+}
+
+package() {
+ cd "$_reponame-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ cp fdic "$pkgdir/usr/bin"
+}