summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Landau2016-09-15 22:37:11 +0300
committerDaniel Landau2016-09-15 22:37:11 +0300
commit6516e478348d8a4071a525f11db6d4be0d3f11c5 (patch)
tree8345f974b68a7b01ef5d107fc453e0e7866f4173
parent5aebcbf106e0b2a3e73b0df3a612e751c97e6970 (diff)
downloadaur-6516e478348d8a4071a525f11db6d4be0d3f11c5.tar.gz
Update to 0.7.0
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD16
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 554faa61eca2..97f91110637b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
# Generated by mksrcinfo v8
-# Thu Jun 9 13:21:55 UTC 2016
+# Thu Sep 15 19:37:06 UTC 2016
pkgbase = fdroidserver
pkgdesc = F-Droid repository management tools
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
epoch = 2
url = https://gitlab.com/fdroid/fdroidserver
arch = any
license = GPL3
- makedepends = python2-setuptools
- makedepends = python2-pillow
- makedepends = python2-paramiko
+ makedepends = python-setuptools
+ makedepends = python-pillow
+ makedepends = python-paramiko
makedepends = java-environment
- depends = python2
- depends = python2-pyasn1
- depends = python2-pyasn1-modules
- depends = python2-magic
- depends = python2-requests
- depends = python2-yaml
+ depends = python
+ depends = python-pyasn1
+ depends = python-pyasn1-modules
+ depends = python-magic
+ depends = python-requests
+ depends = python-yaml
optdepends = android-sdk: Build apps from source
optdepends = android-sdk-build-tools: Work with apks in the repository
optdepends = android-sdk-platform-tools: Ability to install apps to connected devices
@@ -30,15 +30,15 @@ pkgbase = fdroidserver
optdepends = git: Download app sources that use git or svn (via git svn)
optdepends = mercurial: Download app sources that use hg
optdepends = bzr: Download app sources that use bzr
- optdepends = python2-pillow: Resize and manage app icons
- optdepends = python2-paramiko: SSH2 support
+ optdepends = python-pillow: Resize and manage app icons
+ optdepends = python-paramiko: SSH2 support
optdepends = rsync: Transfer repo files to the web server
optdepends = vagrant: Buildserver virtual machine support
optdepends = virtualbox: Buildserver virtual machine support
optdepends = wordpress: Web repository plugin
options = !emptydirs
- source = https://gitlab.com/fdroid/fdroidserver/repository/archive.tar.gz?ref=0.6.0
- sha256sums = 0bce8cd575a30ade8302828bad857bce3dff97708bf0b7a81d9cf4696bc04c4a
+ source = https://gitlab.com/fdroid/fdroidserver/repository/archive.tar.gz?ref=0.7.0
+ sha256sums = 2c59775efd65cc60f0dd310242739b8a070f515205c4f4f7beec5ca5e212b073
pkgname = fdroidserver
diff --git a/PKGBUILD b/PKGBUILD
index 2fe982e32cc4..bdb37d40f337 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
-# Maintainer Daniel Landau <daniel.landau@iki.fi>
+# Maintainer: Daniel Landau <daniel.landau@iki.fi>
# Contributor: Prurigro
# Ported from the package by AlexanderR <alexander r at gmx com>
pkgname=fdroidserver
-pkgver=0.6.0
+pkgver=0.7.0
epoch=2
pkgrel=1
pkgdesc="F-Droid repository management tools"
url="https://gitlab.com/fdroid/$pkgname"
license=('GPL3')
-depends=('python2' 'python2-pyasn1' 'python2-pyasn1-modules' 'python2-magic' 'python2-requests' 'python2-yaml')
-makedepends=('python2-setuptools' 'python2-pillow' 'python2-paramiko' 'java-environment')
+depends=('python' 'python-pyasn1' 'python-pyasn1-modules' 'python-magic' 'python-requests' 'python-yaml')
+makedepends=('python-setuptools' 'python-pillow' 'python-paramiko' 'java-environment')
optdepends=(
'android-sdk: Build apps from source'
'android-sdk-build-tools: Work with apks in the repository'
@@ -24,8 +24,8 @@ optdepends=(
'git: Download app sources that use git or svn (via git svn)'
'mercurial: Download app sources that use hg'
'bzr: Download app sources that use bzr'
- 'python2-pillow: Resize and manage app icons'
- 'python2-paramiko: SSH2 support'
+ 'python-pillow: Resize and manage app icons'
+ 'python-paramiko: SSH2 support'
'rsync: Transfer repo files to the web server'
'vagrant: Buildserver virtual machine support'
'virtualbox: Buildserver virtual machine support'
@@ -34,12 +34,12 @@ optdepends=(
arch=('any')
options=(!emptydirs)
source=("https://gitlab.com/fdroid/${pkgname}/repository/archive.tar.gz?ref=${pkgver}")
-sha256sums=('0bce8cd575a30ade8302828bad857bce3dff97708bf0b7a81d9cf4696bc04c4a')
+sha256sums=('2c59775efd65cc60f0dd310242739b8a070f515205c4f4f7beec5ca5e212b073')
package() {
cd "${srcdir}/${pkgname}-${pkgver}-"*
- python2 setup.py install --root="$pkgdir/" --optimize=1 --install-data="/tmp" || true
+ python setup.py install --root="$pkgdir/" --optimize=1 --install-data="/tmp" || true
rm -rf "$pkgdir/tmp"
mkdir -p "$pkgdir/usr/bin"