aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbaris-inandi2022-08-09 22:00:23 +0300
committerbaris-inandi2022-08-09 22:00:23 +0300
commit419958dbcf8c8f2e8d6a276f4ff8c40ca266af3d (patch)
tree6ab6c760c5fa486fd173023154032ac3e2e7b2f6
parent9ee9ed6f4a4acf35aa455e576dc0ad217aecc1ba (diff)
downloadaur-419958dbcf8c8f2e8d6a276f4ff8c40ca266af3d.tar.gz
new release
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile1
-rw-r--r--PKGBUILD14
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae1864a0ea38..e8e0671fbe6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fe
pkgdesc = AUR helper with a familiar subcommand system
- pkgver = 1.1.6
+ pkgver = 1.1.8
pkgrel = 1
url = https://github.com/baris-inandi/fe
arch = x86_64
@@ -13,7 +13,7 @@ pkgbase = fe
depends = pacman-contrib
backup = etc/feparu.conf
backup = etc/fepacman.conf
- source = git+https://github.com/baris-inandi/fe
- md5sums = SKIP
+ source = fe-1.1.8.tar.gz::https://github.com/baris-inandi/fe/archive/refs/tags/1.1.8.tar.gz
+ sha256sums = 08ceb8e6f4b59376783f5acc3130935ecd37b6bc602e676a84d801323c8cf0d1
pkgname = fe
diff --git a/Makefile b/Makefile
index 1e012e1279fc..737dce4712f3 100644
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,7 @@ install:
release:
make clean
+ makepkg -god
make srcinfo
git add -A
git commit --allow-empty -am "new release"
diff --git a/PKGBUILD b/PKGBUILD
index ac00943dcc18..c2ad7cca8c07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Barış İnandıoğlu <68742481+baris-inandi@users.noreply.github.com>
pkgname=fe
-pkgver=1.1.6
+pkgver=1.1.8
pkgrel=1
pkgdesc="AUR helper with a familiar subcommand system"
arch=(x86_64)
@@ -9,22 +9,18 @@ url="https://github.com/baris-inandi/fe"
license=('GPL3')
depends=(bash sudo paru pacman-contrib)
makedepends=(git go)
-source=("git+$url")
-md5sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/baris-inandi/fe/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('08ceb8e6f4b59376783f5acc3130935ecd37b6bc602e676a84d801323c8cf0d1')
backup=("etc/feparu.conf" "etc/fepacman.conf")
pkgver() {
cd "$pkgname"
- printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-}
-
-prepare() {
- cd "$pkgname"
- git checkout tags/$pkgver -b $pkgver
+ printf "%s" "$(git describe --tags --abbrev=0 | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {
cd "$pkgname"
+ git checkout $(git describe --tags --abbrev=0)
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"