aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbaris-inandi2022-08-01 01:24:54 +0300
committerbaris-inandi2022-08-01 01:24:54 +0300
commit4d3371ee5ae2f68dbd895a2f5ec6bcb5ee7af368 (patch)
tree6f3b3a9a866256a36062c192ea142d3ef5e6bd2a
parent692e073c1bea61cfe0f7a22066fab587c12a3d7a (diff)
downloadaur-4d3371ee5ae2f68dbd895a2f5ec6bcb5ee7af368.tar.gz
commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
-rw-r--r--install.sh16
3 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48959d051b0a..85542aa64c97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fe
pkgdesc = AUR helper with a familiar subcommand system
- pkgver = 1.0.2
- pkgrel = 1
+ pkgver = 1.0.3
+ pkgrel = 3
url = https://github.com/baris-inandi/fe
arch = x86_64
license = GPLv3
diff --git a/PKGBUILD b/PKGBUILD
index 3fd8f1086993..852945b2aa7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
Maintainer="baris-inandi"
pkgname=fe
-pkgver=1.0.2
-pkgrel=1
+pkgver=1.0.3
+pkgrel=3
epoch=
pkgdesc="AUR helper with a familiar subcommand system"
arch=(x86_64)
@@ -26,5 +26,22 @@ validpgpkeys=()
package() {
cd $pkgname
- bash install.sh
+ mkdir -p ~/.config/paru/
+ if [ ! -e /etc/paru.conf ]; then
+ sudo cp conf/paru.conf /etc/paru.conf
+ fi
+ sudo cp -n conf/pacman.conf /etc/fepacman.conf
+ if type "paru" > /dev/null; then
+ git clone https://github.com/joehillen/paruz.git
+ cd paruz
+ sudo make install
+ cd ..
+ sudo rm -rf paruz
+ else
+ echo "WARN: INSTALL PARU BEFORE USING FE"
+ fi
+ sudo rm -rf /usr/bin/fe
+ go build
+ sudo mv fe /usr/bin/fe
+ sudo rm -rf fe
}
diff --git a/install.sh b/install.sh
deleted file mode 100644
index e244df18f566..000000000000
--- a/install.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/usr/bin/bash
-
-mkdir -p ~/.config/paru/
-if [ ! -e /etc/paru.conf ]; then
- cp conf/paru.conf /etc/paru.conf
-fi
-cp -n conf/pacman.conf /etc/fepacman.conf
-if type "paru" > /dev/null; then
- paru -S --removemake --skipreview --needed paruz
-else
- echo "WARN: INSTALL PARU BEFORE USING FE"
-fi
-rm -rf /usr/bin/fe
-go build
-mv fe /usr/bin/fe
-rm -rf fe