aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbaris-inandi2022-08-09 22:20:44 +0300
committerbaris-inandi2022-08-09 22:20:44 +0300
commitb394abb93b033b1dca2a7417b58b1a731ca0b19c (patch)
tree5c98484fb0d7647f40cdebe50d326c76adbea070
parent419958dbcf8c8f2e8d6a276f4ff8c40ca266af3d (diff)
downloadaur-b394abb93b033b1dca2a7417b58b1a731ca0b19c.tar.gz
new release
-rw-r--r--Makefile4
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 737dce4712f3..787080e4ab74 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
clean:
- sudo rm -rf pkg/ src/ fe/ *.zst
+ sudo rm -rf pkg/ src/ fe/ *.zst *.tar.xz
srcinfo:
makepkg --printsrcinfo > .SRCINFO
@@ -12,7 +12,7 @@ install:
release:
make clean
- makepkg -god
+ makepkg -g
make srcinfo
git add -A
git commit --allow-empty -am "new release"
diff --git a/PKGBUILD b/PKGBUILD
index c2ad7cca8c07..c0a19f7edc9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,13 +13,9 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/baris-inandi/fe/archive/ref
sha256sums=('08ceb8e6f4b59376783f5acc3130935ecd37b6bc602e676a84d801323c8cf0d1')
backup=("etc/feparu.conf" "etc/fepacman.conf")
-pkgver() {
- cd "$pkgname"
- printf "%s" "$(git describe --tags --abbrev=0 | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-}
-
build() {
- cd "$pkgname"
+ tar xvf fe-$pkgver.tar.gz
+ cd "$pkgname-$pkgver"
git checkout $(git describe --tags --abbrev=0)
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
@@ -30,7 +26,7 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
install -Dm644 conf/pacman.conf "$pkgdir"/etc/fepacman.conf
install -Dm644 conf/paru.conf "$pkgdir"/etc/feparu.conf
install -Dm755 "$pkgname-$pkgver-$pkgrel" "$pkgdir"/usr/bin/$pkgname