summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Böger2016-10-28 17:10:16 +0200
committerLukas Böger2016-10-28 17:10:16 +0200
commitac1272f2d073e03868acbbe4c99d30b5d8d4bb94 (patch)
treeccd12b92b0cd5a2a689189ef00cb03d64692cea1
downloadaur-ac1272f2d073e03868acbbe4c99d30b5d8d4bb94.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD57
-rw-r--r--feappv.install14
-rw-r--r--makefile19
5 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de8e641f00dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = feappv
+ pkgdesc = A finite element analysis program
+ pkgver = 31
+ pkgrel = 1
+ url = http://www.ce.berkeley.edu/projects/feap/feappv
+ install = feappv.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = gcc-fortran
+ depends = libx11
+ source = http://www.ce.berkeley.edu/projects/feap/feappv/feappv31.zip
+ md5sums = 6031611765744f2cf51b4d928be38a0b
+
+pkgname = feappv
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19f058d18919
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Lukas Böger <dev___AT___lboeger___DOT___de>
+
+pkgname=feappv
+pkgver=31
+pkgrel=1
+
+pkgdesc='A finite element analysis program'
+url='http://www.ce.berkeley.edu/projects/feap/feappv'
+
+arch=('i686' 'x86_64')
+license=('custom')
+
+makedepends=('cmake' 'gcc-fortran')
+depends=('libx11')
+install="${pkgname}.install"
+
+source=("${url}/${pkgname}${pkgver}.zip")
+
+md5sums=('6031611765744f2cf51b4d928be38a0b')
+
+_cmakeBuildDir=build
+
+build() {
+ test -d $_cmakeBuildDir || mkdir $_cmakeBuildDir
+ cd $_cmakeBuildDir
+
+ FFLAGS="-O0" cmake ../ver${pkgver}
+
+ make
+
+ ar rv libFeappvLib.a CMakeFiles/feappv.dir/main/feappv.f.o
+
+ echo 'Copyright (c) 1984-2013: Robert L. Taylor' > LICENSE
+}
+
+package() {
+ _includeTargetDir="${pkgdir}/usr/include/${pkgname}"
+ _shareTargetDir="${pkgdir}/usr/share/${pkgname}"
+
+ mkdir -pm 755 ${_shareTargetDir}
+ install -Dm 644 ../{makefile,example.f} ${_shareTargetDir}
+
+ cd $_cmakeBuildDir
+
+ install -m644 -D libFeappvLib.a "${pkgdir}/usr/lib/lib${pkgname}${pkgver}.a"
+ ln -s "lib${pkgname}${pkgver}.a" "${pkgdir}/usr/lib/lib${pkgname}.a"
+ install -m644 -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m755 -D feappv "${pkgdir}/usr/bin/${pkgname}"
+ install -m644 -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "${srcdir}/ver${pkgver}/include"
+
+ mkdir -pm 755 ${_includeTargetDir}
+ cp -r * ${_includeTargetDir}
+ chmod -R 755 ${_includeTargetDir}/integer[48]
+ chmod -R 644 ${_includeTargetDir}/{*.h,integer[48]/*.h}
+}
diff --git a/feappv.install b/feappv.install
new file mode 100644
index 000000000000..d66a22d1a82a
--- /dev/null
+++ b/feappv.install
@@ -0,0 +1,14 @@
+
+post_install() {
+cat << EOF
+
+Both an executable 'feappv' and the library have been installed. While
+the executable can be used for running the element/material functions that
+are already implemented, the archive is needed for compiling your own
+elements and material laws.
+
+A dummy example with a makefile and an empty user element can be found in
+/usr/share/feappv/.
+EOF
+}
+
diff --git a/makefile b/makefile
new file mode 100644
index 000000000000..60f7cad12bff
--- /dev/null
+++ b/makefile
@@ -0,0 +1,19 @@
+
+FC = gfortran
+FFLAGS = -O0
+LDFLAGS = -lX11 -lfeappv
+FINCLUDE = -I/usr/include/feappv -I/usr/include/feappv/integer8
+
+OBJ = example.o
+FEAP = feap
+
+$(FEAP): $(OBJ)
+ $(FC) -o $(FEAP) $(OBJ) $(LDFLAGS)
+
+.f.o:
+ $(FC) -c $(FFLAGS) $(FINCLUDE) $*.f -o $*.o
+
+clean:
+ rm -f $(OBJ) $(FEAP)
+
+.PHONY: clean