summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Kescher2023-01-17 22:15:50 +0100
committerJeremy Kescher2023-01-17 22:15:50 +0100
commit28979ea71dbf94affd10c1e9181c9fe3b4f39d92 (patch)
treeefb2c37832504826e1246c99af9b7f8a7ce70f1c
parent67538956be6fd0757730a863fe036e9f187be5b1 (diff)
downloadaur-28979ea71dbf94affd10c1e9181c9fe3b4f39d92.tar.gz
v2.2.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 264201de3c32..7ea645b492bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = monero-feather
pkgdesc = A free Monero desktop wallet
- pkgver = 2.1.0
+ pkgver = 2.2.3
pkgrel = 1
url = https://featherwallet.org
arch = x86_64
@@ -8,27 +8,29 @@ pkgbase = monero-feather
makedepends = git
makedepends = cmake
makedepends = boost
- depends = libzip
depends = boost-libs
+ depends = expat
+ depends = hidapi
+ depends = libgcrypt
+ depends = libsodium
+ depends = libudev.so
depends = libunwind
+ depends = libusb
+ depends = libzip
depends = openssl
- depends = hidapi
depends = protobuf
- depends = libusb
- depends = libgcrypt
depends = qrencode
- depends = libsodium
- depends = expat
depends = qt6-base
- depends = qt6-websockets
+ depends = qt6-multimedia
depends = qt6-svg
+ depends = qt6-websockets
depends = tor
- depends = zbar
depends = unbound
+ depends = zbar
provides = monero-feather
conflicts = monero-feather
conflicts = monero-feather-git
- source = monero-feather::git+https://github.com/feather-wallet/feather.git#tag=2.1.0
+ source = monero-feather::git+https://github.com/feather-wallet/feather.git#tag=2.2.3
sha256sums = SKIP
pkgname = monero-feather
diff --git a/PKGBUILD b/PKGBUILD
index ccb42181bfaf..6ac90de12354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Based on https://aur.archlinux.org/packages/monero-feather-git/
pkgname='monero-feather'
-pkgver=2.1.0
+pkgver=2.2.3
pkgrel=1
pkgdesc='A free Monero desktop wallet'
license=('BSD')
arch=('x86_64')
url="https://featherwallet.org"
-depends=('libzip' 'boost-libs' 'libunwind' 'openssl' 'hidapi' 'protobuf' 'libusb' 'libgcrypt'
- 'qrencode' 'libsodium' 'expat' 'qt6-base' 'qt6-websockets' 'qt6-svg' 'tor' 'zbar' 'unbound')
+depends=('boost-libs' 'expat' 'hidapi' 'libgcrypt' 'libsodium' 'libudev.so' 'libunwind' 'libusb' 'libzip'
+ 'openssl' 'protobuf' 'qrencode' 'qt6-base' 'qt6-multimedia' 'qt6-svg' 'qt6-websockets' 'tor' 'unbound' 'zbar')
makedepends=('git' 'cmake' 'boost')
provides=('monero-feather')
conflicts=('monero-feather' 'monero-feather-git')
@@ -22,20 +22,20 @@ sha256sums=('SKIP')
prepare() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive
- # Fix for https://github.com/feather-wallet/feather/issues/33
- # Taken from: https://github.com/gentoo-monero/gentoo-monero/blob/6d409a872a5f530ab0c6003c92741f1564ccee4b/net-misc/feather/feather-2.1.0.ebuild#L75-L76
- echo "#define FEATHER_VERSION \"${pkgver}\"" >> src/config-feather.h
- echo "#define TOR_VERSION \"NOT_EMBEDDED\"" >> src/config-feather.h
+ rm -rf build/*
+ mkdir -p build
+ cd build
+ cmake ..
}
build() {
- cd "${srcdir}/${pkgname}"
- make release
+ cd "${srcdir}/${pkgname}/build"
+ cmake --build .
}
package() {
install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm755 "${srcdir}/${pkgname}/build/release/bin/feather" "${pkgdir}/usr/bin/feather"
+ install -Dm755 "${srcdir}/${pkgname}/build/bin/feather" "${pkgdir}/usr/bin/feather"
install -Dm644 "${srcdir}/${pkgname}/src/assets/feather.desktop" "${pkgdir}/usr/share/applications/feather.desktop"
install -Dm644 "${srcdir}/${pkgname}/src/assets/images/feather.png" "${pkgdir}/usr/share/pixmaps/feather.png"
}