summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2022-03-05 22:56:42 +0100
committerPeter Mattern2022-03-05 22:56:42 +0100
commite79bca49ffb7872a2c155ce1d9ae7eec0db1040e (patch)
tree335b0923c37b3116deb9781d67343cbbc472c512
parent25a3bb30554cda9708a5b44f9b88d5e7c13b84d0 (diff)
downloadaur-e79bca49ffb7872a2c155ce1d9ae7eec0db1040e.tar.gz
Switch to cmake. Enable localization and spell checking.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4975677df18..37cd0f069468 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = feathernotes-git
pkgdesc = Lightweight Qt hierarchical notes-manager for Linux.
- pkgver = 0.4.6.18.g9f99845
+ pkgver = 0.10.0.10.gf0a367c
pkgrel = 1
- url = https://github.com/tsujan/FeatherNotes
+ url = https://github.com/tsujan/feathernotes
arch = i686
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
depends = qt5-x11extras
depends = qt5-svg
depends = shared-mime-info
depends = desktop-file-utils
+ depends = hunspell
optdepends = qt5-translations: localized keyboard shortcuts
provides = feathernotes
conflicts = feathernotes
- source = feathernotes::git+https://github.com/tsujan/FeatherNotes.git
+ source = feathernotes::git+https://github.com/tsujan/feathernotes.git
sha256sums = SKIP
pkgname = feathernotes-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 983a0cd5d7d7..be8ddad139ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
_pkgname=feathernotes
pkgname=$_pkgname-git
-pkgver=0.4.6.18.g9f99845
+pkgver=0.10.0.10.gf0a367c
pkgrel=1
pkgdesc='Lightweight Qt hierarchical notes-manager for Linux.'
arch=('i686' 'x86_64')
-url='https://github.com/tsujan/FeatherNotes'
+url='https://github.com/tsujan/feathernotes'
license=('GPL3')
-depends=('qt5-x11extras' 'qt5-svg' 'shared-mime-info' 'desktop-file-utils')
-makedepends=('git')
+depends=('qt5-x11extras' 'qt5-svg' 'shared-mime-info' 'desktop-file-utils' 'hunspell')
+makedepends=('git' 'cmake' 'qt5-tools')
optdepends=('qt5-translations: localized keyboard shortcuts')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/tsujan/FeatherNotes.git")
+source=("$_pkgname::git+${url}.git")
sha256sums=("SKIP")
pkgver() {
@@ -24,11 +24,11 @@ pkgver() {
build() {
rm -Rf build && mkdir build
cd build
- qmake $srcdir/$_pkgname/ CONFIG+=debug
+ cmake $srcdir/$_pkgname/
make
}
package() {
cd build
- make INSTALL_ROOT=$pkgdir install
+ make DESTDIR=$pkgdir install
}