summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2022-04-27 14:19:10 +0200
committerPeter Mattern2022-04-27 14:19:10 +0200
commitc44db99b8cdb15bf436d1f2d027c2fce35a7d17b (patch)
tree3955276360be0cce942694319c80bfe8de451693
parent34f51e0fe1e71da33fa2407b7c8e8f8c422b0752 (diff)
downloadaur-c44db99b8cdb15bf436d1f2d027c2fce35a7d17b.tar.gz
Replace qmake with cmake
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ceb05355beca..bc6796d10ba4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,11 +2,12 @@ pkgbase = featherpad-git
pkgdesc = Lightweight Qt5 plain text editor for Linux
pkgver = 0.10.0.2.gac3e510
pkgrel = 1
- url = https://github.com/tsujan/FeatherPad
+ url = https://github.com/tsujan/featherpad
arch = i686
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = cmake
makedepends = qt5-tools
depends = qt5-svg
depends = qt5-x11extras
@@ -16,8 +17,7 @@ pkgbase = featherpad-git
optdepends = qt5-translations: localized keyboard shortcuts
provides = featherpad
conflicts = featherpad
- source = featherpad::git+https://github.com/tsujan/FeatherPad.git
+ source = git+https://github.com/tsujan/featherpad.git
sha256sums = SKIP
pkgname = featherpad-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 664344beeda9..b97753a34aea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@ pkgver=0.10.0.2.gac3e510
pkgrel=1
pkgdesc='Lightweight Qt5 plain text editor for Linux'
arch=('i686' 'x86_64')
-url='https://github.com/tsujan/FeatherPad'
+url='https://github.com/tsujan/featherpad'
license=('GPL3')
depends=('qt5-svg' 'qt5-x11extras' 'hunspell' 'desktop-file-utils' 'gtk-update-icon-cache')
-makedepends=('git' 'qt5-tools')
+makedepends=('git' 'cmake' 'qt5-tools')
optdepends=('qt5-translations: localized keyboard shortcuts')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/tsujan/FeatherPad.git")
+source=("git+${url}.git")
sha256sums=("SKIP")
pkgver() {
@@ -24,11 +24,11 @@ pkgver() {
build() {
rm -Rf build && mkdir build
cd build
- qmake $srcdir/$_pkgname/ CONFIG+=debug
+ cmake $srcdir/$_pkgname/
make
}
package() {
cd build
- make INSTALL_ROOT=$pkgdir install
+ make DESTDIR="${pkgdir}" install
}