summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSung Mingi2022-06-19 10:14:52 +0900
committerSung Mingi2022-06-19 10:15:15 +0900
commit2332aebe8262944d7973065f9d69debf24a74861 (patch)
treeb8e524e0290c9029514bb7fa9f3f020e5d68f2f5
parentb894819443c89ff5fe961d9b4617100211f0c6a8 (diff)
downloadaur-2332aebe8262944d7973065f9d69debf24a74861.tar.gz
Fix provides, conflicts, and $_pkgname
Signed-off-by: Sung Mingi <FiestaLake@protonmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48c8bfec7ded..3e7991919228 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,6 +13,8 @@ pkgbase = featherpad-qt5
depends = qt5-svg
depends = qt5-translations
depends = qt5-x11extras
+ provides = featherpad
+ conflicts = featherpad
source = https://github.com/tsujan/FeatherPad/releases/download/V1.3.0/FeatherPad-1.3.0.tar.xz
source = https://github.com/tsujan/FeatherPad/releases/download/V1.3.0/FeatherPad-1.3.0.tar.xz.asc
source = featherpad.appdata.xml
diff --git a/PKGBUILD b/PKGBUILD
index f85e1487e3f8..993fb0f241e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,6 +4,7 @@
# Contributor: Peter Mattern <pmattern at arcor dot de>
pkgname=featherpad-qt5
+_pkgname=featherpad
pkgver=1.3.0
pkgrel=1
pkgdesc='Lightweight Qt5 plain text editor'
@@ -12,6 +13,8 @@ url='https://github.com/tsujan/FeatherPad'
license=('GPL3')
depends=('hicolor-icon-theme' 'hunspell' 'qt5-svg' 'qt5-translations' 'qt5-x11extras')
makedepends=('cmake' 'ninja' 'qt5-tools')
+provides=($_pkgname)
+conflicts=($_pkgname)
source=("https://github.com/tsujan/FeatherPad/releases/download/V$pkgver/FeatherPad-$pkgver.tar.xz"{,.asc}
'featherpad.appdata.xml')
sha256sums=('6fd327b5800bc48d0d88ca5666d173dfeecdc76d0a2654b87df8cd96df412617'
@@ -26,5 +29,5 @@ build() {
package() {
DESTDIR="$pkgdir" cmake --install build
- install -Dm644 $pkgname.appdata.xml "$pkgdir/usr/share/metainfo/$pkgname.appdata.xml"
+ install -Dm644 $_pkgname.appdata.xml "$pkgdir/usr/share/metainfo/$_pkgname.appdata.xml"
}