summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSung Mingi2022-06-19 10:07:51 +0900
committerSung Mingi2022-06-19 10:07:51 +0900
commitb894819443c89ff5fe961d9b4617100211f0c6a8 (patch)
tree1d1b46e1b4416fa8eca2f5d9467ad89d953cc0bb
downloadaur-b894819443c89ff5fe961d9b4617100211f0c6a8.tar.gz
1.3.0-1
Signed-off-by: Sung Mingi <FiestaLake@protonmail.com>
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD30
-rw-r--r--featherpad.appdata.xml45
3 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48c8bfec7ded
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = featherpad-qt5
+ pkgdesc = Lightweight Qt5 plain text editor
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/tsujan/FeatherPad
+ arch = any
+ license = GPL3
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = qt5-tools
+ depends = hicolor-icon-theme
+ depends = hunspell
+ depends = qt5-svg
+ depends = qt5-translations
+ depends = qt5-x11extras
+ source = https://github.com/tsujan/FeatherPad/releases/download/V1.3.0/FeatherPad-1.3.0.tar.xz
+ source = https://github.com/tsujan/FeatherPad/releases/download/V1.3.0/FeatherPad-1.3.0.tar.xz.asc
+ source = featherpad.appdata.xml
+ validpgpkeys = 19DFDF3A579BD509DBB572D8BE793007AD22DF7E
+ sha256sums = 6fd327b5800bc48d0d88ca5666d173dfeecdc76d0a2654b87df8cd96df412617
+ sha256sums = SKIP
+ sha256sums = d67bc310f4c31257b795beabbce2d0887640088b0fe3040307906da0d9f760d9
+
+pkgname = featherpad-qt5
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f85e1487e3f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sung Mingi <FiestaLake@protonmail.com>
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Peter Mattern <pmattern at arcor dot de>
+
+pkgname=featherpad-qt5
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='Lightweight Qt5 plain text editor'
+arch=('any')
+url='https://github.com/tsujan/FeatherPad'
+license=('GPL3')
+depends=('hicolor-icon-theme' 'hunspell' 'qt5-svg' 'qt5-translations' 'qt5-x11extras')
+makedepends=('cmake' 'ninja' 'qt5-tools')
+source=("https://github.com/tsujan/FeatherPad/releases/download/V$pkgver/FeatherPad-$pkgver.tar.xz"{,.asc}
+ 'featherpad.appdata.xml')
+sha256sums=('6fd327b5800bc48d0d88ca5666d173dfeecdc76d0a2654b87df8cd96df412617'
+ 'SKIP'
+ 'd67bc310f4c31257b795beabbce2d0887640088b0fe3040307906da0d9f760d9')
+validpgpkeys=('19DFDF3A579BD509DBB572D8BE793007AD22DF7E')
+
+build() {
+ cmake -S FeatherPad-$pkgver -B build -G Ninja -DCMAKE_INSTALL_PREFIX='/usr'
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+ install -Dm644 $pkgname.appdata.xml "$pkgdir/usr/share/metainfo/$pkgname.appdata.xml"
+}
diff --git a/featherpad.appdata.xml b/featherpad.appdata.xml
new file mode 100644
index 000000000000..7cac6e641aef
--- /dev/null
+++ b/featherpad.appdata.xml
@@ -0,0 +1,45 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop-application">
+ <id>com.github.FeatherPad</id>
+ <launchable type="desktop-id">featherpad.desktop</launchable>
+ <name>FeatherPad</name>
+ <summary>Lightweight Qt plain text editor</summary>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <description>
+ <p>FeatherPad is a lightweight Qt5 plain-text editor for Linux. It is independent of any desktop environment and has:</p>
+ <ul>
+ <li>Drag-and-drop support, including tab detachment and attachment</li>
+ <li>X11 virtual desktop awareness (using tabs on current desktop but opening a new window on another)</li>
+ <li>An optionally permanent search-bar with a different search entry for each tab</li>
+ <li>Instant highlighting of found matches when searching</li>
+ <li>A docked window for text replacement</li>
+ <li>Support for showing line numbers and jumping to a specific line</li>
+ <li>Optional selection highlighting</li>
+ <li>Automatic detection of text encoding as far as possible and optional saving with encoding</li>
+ <li>Syntax highlighting for common programming languages</li>
+ <li>Ability to open URLs with appropriate applications</li>
+ <li>Session management</li>
+ <li>Side-pane mode</li>
+ <li>Auto-saving</li>
+ <li>Spell checking with Hunspell</li>
+ <li>Printing</li>
+ <li>Text zooming</li>
+ <li>Appropriate but non-interrupting prompts</li>
+ <li>Other features that can be found in its settings, on its menus or when it is actually used.</li>
+ </ul>
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image>https://raw.githubusercontent.com/tsujan/FeatherPad/master/screenshots/Tabs.png</image>
+ </screenshot>
+ <screenshot>
+ <image>https://raw.githubusercontent.com/tsujan/FeatherPad/master/screenshots/Side-Pane.png</image>
+ </screenshot>
+ </screenshots>
+ <url type="bugtracker">https://github.com/tsujan/FeatherPad/issues</url>
+ <url type="homepage">https://github.com/tsujan/FeatherPad</url>
+ <developer_name>Pedram Pourang, a.k.a. Tsu Jan</developer_name>
+ <update_contact>tsujan2000@gmail.com</update_contact>
+ <translation type="qt">featherpad</translation>
+</component>