summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2023-07-19 11:22:46 +0200
committerredtide2023-07-19 11:26:08 +0200
commit3ca4b6ed6c86d487256e6bcd05dd28cf38b93adb (patch)
treee49808a19efe86ba423857881e1e24f098deae1e
downloadaur-3ca4b6ed6c86d487256e6bcd05dd28cf38b93adb.tar.gz
First commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7967cbebf15b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = featherpad-qt5-git
+ pkgdesc = Lightweight Qt plain text editor (Qt5 version)
+ pkgver = V1.4.1.r7.g1084b89f
+ pkgrel = 1
+ url = https://github.com/tsujan/FeatherPad
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = qt5-tools
+ depends = hicolor-icon-theme
+ depends = hunspell
+ depends = qt5-svg
+ provides = featherpad
+ conflicts = featherpad
+ source = featherpad::git+https://github.com/tsujan/FeatherPad
+ sha512sums = SKIP
+ b2sums = SKIP
+
+pkgname = featherpad-qt5-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55a8fc9b5674
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: redtide <redtid3@gmail.com>
+
+_pkgname=featherpad
+pkgname=$_pkgname-qt5-git
+pkgver=V1.4.1.r7.g1084b89f
+pkgrel=1
+pkgdesc="Lightweight Qt plain text editor (Qt5 version)"
+arch=(x86_64)
+url='https://github.com/tsujan/FeatherPad'
+license=(GPL3)
+depends=(
+ hicolor-icon-theme
+ hunspell
+ qt5-svg
+)
+makedepends=(
+ cmake
+ git
+ qt5-tools
+)
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($_pkgname::git+$url)
+b2sums=('SKIP')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ local options=(
+ -B build
+ -D CMAKE_BUILD_TYPE=None
+ -D CMAKE_INSTALL_PREFIX=/usr
+ -S .
+ -W no-dev
+ )
+ cmake "${options[@]}"
+ cmake --build build --verbose
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ DESTDIR="$pkgdir" cmake --install build
+}