summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNbiba Bedis2018-11-11 11:11:05 +0100
committerNbiba Bedis2018-11-11 11:11:05 +0100
commitbc73902686ed8c6921a130eb2b87cee4bc652da2 (patch)
tree766947915ede8b99bc34a0c3079cdf4e4bc28e8a
parent4f41c432c1e4985bf9ff59e888ae7b60e228fc3c (diff)
downloadaur-bc73902686ed8c6921a130eb2b87cee4bc652da2.tar.gz
fix format add sed to makedepends
-rw-r--r--PKGBUILD67
1 files changed, 34 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4438216d6c5..04aa3ffc191f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
- # Maintainer: Nbiba bedis <bedisnbiba@gmail.com>
-
- pkgname=fedora-firefox-wayland-bin
- pkgver=63.0.1
- pkgrel=3
- pkgdesc="Fedora's firefox build wtih wayland enabled by default"
- arch=(x86_64)
- license=(MPL GPL LGPL)
- url="https://www.mozilla.org/firefox/"
- provides=('firefox')
- conflicts=('firefox')
- options=(!emptydirs !strip)
- depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
- ffmpeg nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
- optdepends=('networkmanager: Location detection via available WiFi networks'
- 'libnotify: Notification integration'
- 'pulseaudio: Audio support'
- 'speech-dispatcher: Text-to-Speech')
- source=("https://kojipkgs.fedoraproject.org//packages/firefox/63.0.1/3.fc30/x86_64/firefox-63.0.1-3.fc30.x86_64.rpm")
- md5sums=('a4f5ef650ddb062de0a9031b79cb4979')
-
- prepare() {
- # remove a bit of fedora's custom sutff
- rm -f usr/lib64/firefox/browser/defaults/preferences/firefox-redhat-default-prefs.js
- # default to wayland
- sed -i -e 's:GDK_BACKEND=x11:GDK_BACKEND=wayland:' usr/bin/firefox
- }
-
- package() {
- rm -rf usr/lib
- mv usr/lib64 usr/lib
- cp -r usr/ $pkgdir/
- }
+# Maintainer: Nbiba bedis <bedisnbiba@gmail.com>
+
+pkgname=fedora-firefox-wayland-bin
+pkgver=63.0.1
+pkgrel=4
+pkgdesc="Fedora's firefox build wtih wayland enabled by default"
+arch=(x86_64)
+license=(MPL GPL LGPL)
+url="https://www.mozilla.org/firefox/"
+provides=('firefox')
+conflicts=('firefox')
+options=(!emptydirs !strip)
+makedepends=(sed)
+depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
+ ffmpeg nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
+optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'libnotify: Notification integration'
+ 'pulseaudio: Audio support'
+ 'speech-dispatcher: Text-to-Speech')
+source=("https://kojipkgs.fedoraproject.org//packages/firefox/63.0.1/3.fc30/x86_64/firefox-63.0.1-3.fc30.x86_64.rpm")
+md5sums=('a4f5ef650ddb062de0a9031b79cb4979')
+
+prepare() {
+ # remove a bit of fedora's custom sutff
+ rm -f usr/lib64/firefox/browser/defaults/preferences/firefox-redhat-default-prefs.js
+ # default to wayland
+ sed -i -e 's:GDK_BACKEND=x11:GDK_BACKEND=wayland:' usr/bin/firefox
+}
+
+package() {
+ rm -rf usr/lib
+ mv usr/lib64 usr/lib
+ cp -r usr/ $pkgdir/
+}