summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNbiba Bedis2018-11-11 10:53:07 +0100
committerNbiba Bedis2018-11-11 10:53:07 +0100
commitc5d565e62603c77a22fdcfc66d6cb490fd7700d1 (patch)
tree5d23eae14bee5d8eae3c0cf9c1713ab6e4c2b49c
downloadaur-c5d565e62603c77a22fdcfc66d6cb490fd7700d1.tar.gz
initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD32
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b44d52d4aed2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = fedora-firefox-wayland-bin
+ pkgdesc = Fedora's firefox build wtih wayland enabled by default
+ pkgver = 63.0.1
+ pkgrel = 1
+ url = https://www.mozilla.org/firefox/
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = gtk3
+ depends = mozilla-common
+ depends = libxt
+ depends = startup-notification
+ depends = mime-types
+ depends = dbus-glib
+ depends = ffmpeg
+ depends = nss
+ depends = hunspell-en_US
+ depends = sqlite
+ depends = ttf-font
+ depends = libpulse
+ depends = libvpx
+ depends = icu
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = libnotify: Notification integration
+ optdepends = pulseaudio: Audio support
+ optdepends = speech-dispatcher: Text-to-Speech
+ provides = firefox
+ conflicts = firefox
+ options = !emptydirs
+ options = !strip
+ source = https://kojipkgs.fedoraproject.org//packages/firefox/63.0.1/3.fc30/x86_64/firefox-63.0.1-3.fc30.x86_64.rpm
+ md5sums = a4f5ef650ddb062de0a9031b79cb4979
+
+pkgname = fedora-firefox-wayland-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cc0e3330336
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nbiba bedis <bedisnbiba@gmail.com>
+
+ pkgname=fedora-firefox-wayland-bin
+ pkgver=63.0.1
+ pkgrel=1
+ pkgdesc="Fedora's firefox build wtih wayland enabled by default"
+ arch=(x86_64)
+ license=(MPL GPL LGPL)
+ url="https://www.mozilla.org/firefox/"
+ provides=('firefox')
+ conflicts=('firefox')
+ options=(!emptydirs !strip)
+ depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
+ ffmpeg nss hunspell-en_US sqlite ttf-font libpulse libvpx icu)
+ optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'libnotify: Notification integration'
+ 'pulseaudio: Audio support'
+ 'speech-dispatcher: Text-to-Speech')
+ source=("https://kojipkgs.fedoraproject.org//packages/firefox/63.0.1/3.fc30/x86_64/firefox-63.0.1-3.fc30.x86_64.rpm")
+ md5sums=('a4f5ef650ddb062de0a9031b79cb4979')
+ prepare() {
+ # remove a bit of fedora sutff (startpage)
+ rm -f usr/lib64/firefox/browser/defaults/preferences/firefox-redhat-default-prefs.js
+ # default to wayland
+ sed -i -e 's:GDK_BACKEND=x11:GDK_BACKEND=wayland:' usr/bin/firefox
+ }
+ package() {
+ rm -rf usr/lib
+ mv usr/lib64 usr/lib
+ cp -r usr/ $pkgdir/
+ }
+