summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiancarlo Razzolini2016-10-25 09:10:34 -0200
committerGiancarlo Razzolini2016-10-25 09:10:34 -0200
commitfaf187ced11cfb585c65909069dca6816a8e9081 (patch)
tree4956042e4397c60ea63b274da12199498f649b42
downloadaur-faf187ced11cfb585c65909069dca6816a8e9081.tar.gz
* Initial release of feed2maildir.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD20
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4675e4c23bd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Oct 25 11:10:25 UTC 2016
+pkgbase = feed2maildir
+ pkgdesc = Read RSS/Atom feeds in your favourite, maildir-compatible email client
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://github.com/sulami/feed2maildir
+ arch = any
+ license = ISC
+ depends = python
+ depends = python-dateutil
+ depends = python-feedparser
+ depends = python-setuptools
+ options = !emptydirs
+ source = feed2maildir-0.3.6.tar.gz::https://github.com/sulami/feed2maildir/archive/0.3.6.tar.gz
+ sha512sums = b5f0ccf2d8b884ee0a8a006ef0bad9fe3ef7770681655e0b969b6bca8074bb0ff37f7fac704b8e6b7d2a66ec473e21ac43f43e4fc999b22d70a56c85771135cc
+
+pkgname = feed2maildir
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bbc7f4aa6d21
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+feed2maildir-*.tar.gz
+feed2maildir-*.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..540bed230650
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Giancarlo Razzolini <grazzolini@gmail.com>
+pkgname=feed2maildir
+pkgver=0.3.6
+pkgrel=1
+pkgdesc="Read RSS/Atom feeds in your favourite, maildir-compatible email client"
+arch=('any')
+url="https://github.com/sulami/feed2maildir"
+license=('ISC')
+depends=('python' 'python-dateutil' 'python-feedparser' 'python-setuptools')
+backup=()
+options=(!emptydirs)
+install=
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('b5f0ccf2d8b884ee0a8a006ef0bad9fe3ef7770681655e0b969b6bca8074bb0ff37f7fac704b8e6b7d2a66ec473e21ac43f43e4fc999b22d70a56c85771135cc')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}