summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitri Kourennyi2021-06-10 11:08:44 -0400
committerDmitri Kourennyi2021-06-10 11:08:44 -0400
commit193ec8594361899000fd43e7c74ce7a446b96c3a (patch)
tree91b4cc275ed2fe0a6bbdaf7b47002ede3b458d53
parentaa89262d098d8b13d0a3fd7633ae393e61cbaceb (diff)
downloadaur-193ec8594361899000fd43e7c74ce7a446b96c3a.tar.gz
Add installation of guide and completions
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD10
3 files changed, 13 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91f06dc6b19b..d48466750a07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = feedgnuplot
pkgdesc = General purpose pipe-oriented plotting tool
pkgver = 1.58
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/dkogan/feedgnuplot
arch = any
license = GPL
@@ -14,4 +14,3 @@ pkgbase = feedgnuplot
b2sums = 0a57d44658661ebc167d3dbcf6000f5dfee0d1dcd22185129a915180611e2588d719fbd7b268869373eff4e5d95ca4660a295dc02431ea27ba7578b7999a07e8
pkgname = feedgnuplot
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..16c18c6136ce
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg
+/src
+
diff --git a/PKGBUILD b/PKGBUILD
index 0ab68c320fed..999d76d44314 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Eric Schulte <[firstname] dot [lastname] at gmx dot com>
pkgname=feedgnuplot
pkgver=1.58
-pkgrel=1
+pkgrel=2
pkgdesc="General purpose pipe-oriented plotting tool"
arch=('any')
url="https://github.com/dkogan/feedgnuplot"
@@ -28,4 +28,12 @@ package() {
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+
+ # Copy shell completions
+ install -D --mode=644 --target-directory="$pkgdir/usr/share/bash-completion/completions/" completions/bash/feedgnuplot
+ install -D --mode=644 --target-directory="$pkgdir/usr/share/zsh/site-functions/" completions/zsh/_feedgnuplot
+
+ # Copy guide
+ install --directory "$pkgdir/usr/share/docs/feedgnuplot"
+ cp --recursive guide "$pkgdir/usr/share/docs/feedgnuplot/"
}