summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2021-02-17 19:55:38 +1300
committerMorgenstern2021-02-17 19:56:22 +1300
commit991d38b295c54a21c7465d8d704f1210374c8b3b (patch)
treed9167481ee3611bedb10e1741935b5a033770860
parentdb6aa9c2022f47cdc84bd6079ad547e3ff052683 (diff)
downloadaur-991d38b295c54a21c7465d8d704f1210374c8b3b.tar.gz
Update to v2.0.0 using Python 3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD61
-rw-r--r--feedindicator.install28
-rw-r--r--fix-makefile.patch217
4 files changed, 268 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fb719b5001f..cf4235353aaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = feedindicator
pkgdesc = RSS feed updates in the indicator/notification area
- pkgver = 1.03
+ pkgver = 2.0.0.20171011
pkgrel = 1
- url = https://github.com/nicolas-raoul/Feedindicator
+ url = https://github.com/feedindicator/Feedindicator
install = feedindicator.install
arch = any
license = GPL3
- makedepends = git
makedepends = xdg-utils
- depends = python2-feedparser
- depends = python2-configobj
- depends = python2-libappindicator
- depends = python2-notify
- depends = python2-gconf
- source = git+https://github.com/nicolas-raoul/feedindicator.git
- md5sums = SKIP
+ depends = libnotify
+ depends = python-configobj
+ depends = python-gobject
+ depends = python-feedparser
+ source = feedindicator-990d56a417be822b7d59da23deada927ab8d2ba6.tar.gz::https://github.com/feedindicator/Feedindicator/archive/990d56a417be822b7d59da23deada927ab8d2ba6.tar.gz
+ source = fix-feed-notifications.patch::https://github.com/jnphilipp/Feedindicator/commit/9565b461e849bbf5985a8c081124d97e3f6216f5.diff
+ source = fix-makefile.patch
+ sha256sums = ca6b457186fbf9253625cb40d141f637060465566e5c4f296e2a99ae4d09c8ac
+ sha256sums = 94ab00bc7e61aa56ed9288e3e0c563eba5388485631ce3cdbf313d9c968f4836
+ sha256sums = 3f5e4be3e76d61923dab4bd62d9e61c2db8a60ad074b4347961aff0f74b1a6f5
pkgname = feedindicator
diff --git a/PKGBUILD b/PKGBUILD
index bb2c5fab4264..d0225ebb2e7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,42 @@
-# Maintainer: Dafta <dafta007@gmail.com>
+# Maintainer: Morgenstern <charles [at] charlesbwise [dot] com>
+# Contributor: Dafta <dafta007@gmail.com>
+
pkgname=feedindicator
-pkgver=1.03
+pkgver=2.0.0.20171011
+_commit=990d56a417be822b7d59da23deada927ab8d2ba6
pkgrel=1
pkgdesc="RSS feed updates in the indicator/notification area"
arch=('any')
-url="https://github.com/nicolas-raoul/Feedindicator"
+url="https://github.com/feedindicator/${pkgname^}"
license=('GPL3')
-depends=('python2-feedparser' 'python2-configobj' 'python2-libappindicator' 'python2-notify' 'python2-gconf')
-makedepends=('git' 'xdg-utils')
-install=feedindicator.install
-
-source=('git+https://github.com/nicolas-raoul/feedindicator.git')
-md5sums=('SKIP')
-_gitname=feedindicator
+depends=('libnotify'
+ 'python-configobj'
+ 'python-gobject'
+ 'python-feedparser')
+makedepends=('xdg-utils')
+install=${pkgname}.install
+source=("${pkgname}-${_commit}.tar.gz::https://github.com/${pkgname}/${pkgname^}/archive/${_commit}.tar.gz"
+ "fix-feed-notifications.patch::https://github.com/jnphilipp/${pkgname^}/commit/9565b461e849bbf5985a8c081124d97e3f6216f5.diff"
+ fix-makefile.patch)
+sha256sums=('ca6b457186fbf9253625cb40d141f637060465566e5c4f296e2a99ae4d09c8ac'
+ '94ab00bc7e61aa56ed9288e3e0c563eba5388485631ce3cdbf313d9c968f4836'
+ '3f5e4be3e76d61923dab4bd62d9e61c2db8a60ad074b4347961aff0f74b1a6f5')
prepare() {
- # adjust shebang
- cd "$srcdir/$_gitname"
- sed -i -e '1 s%^.*$%#!/usr/bin/python2.7%' feedindicator
+ mv "${pkgname^}-${_commit}" "${pkgname}-${pkgver}"
+
+ # Apply feed notifications and makefile fix patches
+ cd "${pkgname}-${pkgver}"
+ patch --strip=1 --input="${srcdir}/fix-feed-notifications.patch"
+ patch --strip=1 --input="${srcdir}/fix-makefile.patch"
}
-package() {
- cd "$srcdir/$_gitname"
-
- mkdir -p $pkgdir/usr/share/feedindicator
-
- cp feedindicator-icon.png $pkgdir/usr/share/feedindicator/feedindicator-icon.png
- cp feedindicator-logo.png $pkgdir/usr/share/feedindicator/feedindicator-logo.png
- cp feedindicator-48x48.png $pkgdir/usr/share/feedindicator/feedindicator-48x48.png
- cp feedindicator.desktop $pkgdir/usr/share/feedindicator/feedindicator.desktop
- cp -r languages/ $pkgdir/usr/share/feedindicator/
- cp -r dark/ $pkgdir/usr/share/feedindicator/
- cp -r light $pkgdir/usr/share/feedindicator/
- cp -r hicolor $pkgdir/usr/share/feedindicator/
-
- mkdir -p $pkgdir/usr/bin
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
- cp feedindicator $pkgdir/usr/bin/feedindicator
- chmod +x $pkgdir/usr/bin/feedindicator
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
}
diff --git a/feedindicator.install b/feedindicator.install
index e87cc22668b7..d38b43405895 100644
--- a/feedindicator.install
+++ b/feedindicator.install
@@ -1,25 +1,13 @@
post_install() {
- xdg-icon-resource install --theme ubuntu-mono-dark --novendor --size 22 /usr/share/feedindicator/dark/indicator-feedindicator.png indicator-feedindicator
- xdg-icon-resource install --theme ubuntu-mono-dark --novendor --size 22 /usr/share/feedindicator/dark/indicator-feedindicator-attention.png indicator-feedindicator-attention
- xdg-icon-resource install --theme ubuntu-mono-light --novendor --size 22 /usr/share/feedindicator/light/indicator-feedindicator.png indicator-feedindicator
- xdg-icon-resource install --theme ubuntu-mono-light --novendor --size 22 /usr/share/feedindicator/light/indicator-feedindicator-attention.png indicator-feedindicator-attention
- xdg-icon-resource install --theme hicolor --novendor --size 22 /usr/share/feedindicator/hicolor/indicator-feedindicator.png indicator-feedindicator
- xdg-icon-resource install --theme hicolor --novendor --size 22 /usr/share/feedindicator/hicolor/indicator-feedindicator-attention.png indicator-feedindicator-attention
- xdg-icon-resource install --theme hicolor --novendor --size 128 --context apps /usr/share/feedindicator/feedindicator-logo.png feedindicator
- xdg-icon-resource install --theme hicolor --novendor --size 48 --context apps /usr/share/feedindicator/feedindicator-48x48.png feedindicator
-
- xdg-desktop-menu install --novendor /usr/share/feedindicator/feedindicator.desktop
+ xdg-icon-resource install --theme hicolor --novendor --size 48 --context apps /usr/share/feedindicator/icons/logo-48x48.png feedindicator
+ xdg-icon-resource install --theme hicolor --novendor --size 128 --context apps /usr/share/feedindicator/icons/logo-128x128.png feedindicator
+ xdg-icon-resource install --theme hicolor --novendor --size 512 /usr/share/feedindicator/icons/active.png feedindicator-active
+ xdg-icon-resource install --theme hicolor --novendor --size 512 /usr/share/feedindicator/icons/attention.png feedindicator-attention
}
post_remove() {
- xdg-icon-resource uninstall --theme ubuntu-mono-dark --size 22 indicator-feedindicator
- xdg-icon-resource uninstall --theme ubuntu-mono-dark --size 22 indicator-feedindicator-attention
- xdg-icon-resource uninstall --theme ubuntu-mono-light --size 22 indicator-feedindicator
- xdg-icon-resource uninstall --theme ubuntu-mono-light --size 22 indicator-feedindicator-attention
- xdg-icon-resource uninstall --theme hicolor --size 22 indicator-feedindicator
- xdg-icon-resource uninstall --theme hicolor --size 22 indicator-feedindicator-attention
- xdg-icon-resource uninstall --theme hicolor --size 128 --context apps feedindicator
- xdg-icon-resource uninstall --theme hicolor --size 48 --context apps feedindicator
-
- xdg-desktop-menu uninstall feedindicator.desktop
+ xdg-icon-resource uninstall --theme hicolor --size 48 --context apps feedindicator
+ xdg-icon-resource uninstall --theme hicolor --size 128 --context apps feedindicator
+ xdg-icon-resource uninstall --theme hicolor --size 512 feedindicator-active
+ xdg-icon-resource uninstall --theme hicolor --size 512 feedindicator-attention
}
diff --git a/fix-makefile.patch b/fix-makefile.patch
new file mode 100644
index 000000000000..a617616940e7
--- /dev/null
+++ b/fix-makefile.patch
@@ -0,0 +1,217 @@
+diff --unified --recursive --text feedindicator-2.0.0.20171011.orig/Makefile feedindicator-2.0.0.20171011.new/Makefile
+--- feedindicator-2.0.0.20171011.orig/Makefile 2017-10-11 04:03:34.000000000 +1300
++++ feedindicator-2.0.0.20171011.new/Makefile 2021-02-17 19:31:00.061377672 +1300
+@@ -1,30 +1,21 @@
+-BASH_COMPLETION_DIR=/usr/share/bash-completion/completions/
+-BIN_DIR=/usr/bin/
+-DOC_DIR=/usr/share/doc/feedindicator/
+-MAN_DIR=/usr/share/man/man1/
+-SHARE_DIR=/usr/share/feedindicator/
++PREFIX ?= /usr
++BIN_DIR = $(PREFIX)/bin
++SHARE_DIR = $(PREFIX)/share/feedindicator
++DESKTOP_DIR = $(PREFIX)/share/applications
++BASH_COMPLETION_DIR = $(PREFIX)/share/bash-completion/completions
+
+
+ all: bin/feedindicator bin/feedindicator.desktop
+
+
+ bin:
+- @mkdir bin
+-
+-
+-build:
+- @mkdir build
+-
+-
+-build/package/DEBIAN: build
+- @mkdir -p build/package/DEBIAN
++ @install -d bin
+
+
+ bin/feedindicator: bin
+- @echo "#!/usr/bin/env bash\n" > bin/feedindicator
++ @echo "#!/usr/bin/env bash" > bin/feedindicator
+ @echo "cd $(SHARE_DIR)" >> bin/feedindicator
+- @echo "python3 -m feedindicator \$$@" >> bin/feedindicator
+- @chmod a+x bin/feedindicator
++ @echo "python -m feedindicator \$$@" >> bin/feedindicator
+
+
+ bin/feedindicator.desktop: bin
+@@ -35,140 +26,45 @@
+ @echo "Exec=feedindicator" >> bin/feedindicator.desktop
+ @echo "Icon=feedindicator" >> bin/feedindicator.desktop
+ @echo "Name=Feedindicator" >> bin/feedindicator.desktop
+- @echo "Comment=A RSS feed reader for the indicator area." >> bin/feedindicator.desktop
++ @echo "Comment=RSS feed applet" >> bin/feedindicator.desktop
+ @echo "Categories=Internet;Network;" >> bin/feedindicator.desktop
+- @chmod a+x bin/feedindicator.desktop
+
+
+-build/package/DEBIAN/md5sums: bin/feedindicator bin/feedindicator.desktop build/copyright build/changelog build/feedindicator.1 build/package/DEBIAN
+- @mkdir -m 755 -p build/package$(BASH_COMPLETION_DIR)
+- @mkdir -m 755 -p build/package$(BIN_DIR)
+- @mkdir -m 755 -p build/package$(DOC_DIR)
+- @mkdir -m 755 -p build/package$(MAN_DIR)
+- @mkdir -m 755 -p build/package$(SHARE_DIR)
+- @find build/package -type d -exec chmod 755 {} \;
+-
+- @cp -r bin/feedindicator build/package$(BIN_DIR)
+- @chmod 755 build/package$(BIN_DIR)feedindicator
+- @cp bin/feedindicator.desktop build/package$(SHARE_DIR)
+- @chmod 755 build/package$(SHARE_DIR)feedindicator.desktop
+- @cp -r feedindicator build/package$(SHARE_DIR)
+- @cp -r icons build/package$(SHARE_DIR)
+- @find build/package$(SHARE_DIR) -type f -exec chmod 644 {} \;
+- @find build/package$(SHARE_DIR) -type d -exec chmod 755 {} \;
+- @cp feedindicator.bash-completion build/package$(BASH_COMPLETION_DIR)
+- @chmod 644 build/package$(BASH_COMPLETION_DIR)feedindicator.bash-completion
+-
+- @cat build/feedindicator.1 | gzip -n9 > build/package$(MAN_DIR)feedindicator.1.gz
+- @chmod 644 build/package$(MAN_DIR)feedindicator.1.gz
+-
+- @cat build/changelog | gzip -n9 > build/package$(DOC_DIR)changelog.gz
+- @chmod 644 build/package$(DOC_DIR)changelog.gz
+-
+- @cp build/copyright build/package$(DOC_DIR)copyright
+- @chmod 644 build/package$(DOC_DIR)copyright
+-
+- @mkdir -p build/package/DEBIAN
+- @md5sum `find build/package -type f -not -path "*DEBIAN*"` > build/md5sums
+- @sed -e "s/build\/package\///" build/md5sums > build/package/DEBIAN/md5sums
+- @chmod 644 build/package/DEBIAN/md5sums
+-
+-
+-build/package/DEBIAN/control: build/package/DEBIAN/md5sums
+- @echo "Package: feedindicator" > build/package/DEBIAN/control
+- @echo "Version: `grep "__version_info__ =" feedindicator/__init__.py | grep -oE "[0-9]+, [0-9]+, [0-9]+" | sed -e "s/, /./g"`" >> build/package/DEBIAN/control
+- @echo "Section: web" >> build/package/DEBIAN/control
+- @echo "Priority: optional" >> build/package/DEBIAN/control
+- @echo "Architecture: all" >> build/package/DEBIAN/control
+- @echo "Depends: python3 (>= 3), python3-feedparser, python3-gi, python3-configobj, hicolor-icon-theme, indicator-application, xdg-utils" >> build/package/DEBIAN/control
+- @echo "Installed-Size: `du -csk build/package/usr | grep -oE "[0-9]+\stotal" | cut -f 1`" >> build/package/DEBIAN/control
+- @echo "Maintainer: Nathanael Philipp <mail@jnphilipp.org>" >> build/package/DEBIAN/control
+- @echo "Homepage: https://github.com/jnphilipp/Feedindicator" >> build/package/DEBIAN/control
+- @echo "Description: RSS feed updates in the indicator area\n Editable, sortable list of feed URLs.\n Notification popups of new feed items.\n Adjustable update timer." >> build/package/DEBIAN/control
+-
+-
+-build/package/DEBIAN/postinst: build/package/DEBIAN
+- @echo "#!/bin/sh -e" > build/package/DEBIAN/postinst
+- @echo "xdg-icon-resource install --theme hicolor --novendor --size 512 $(SHARE_DIR)icons/active.png feedindicator-active" >> build/package/DEBIAN/postinst
+- @echo "xdg-icon-resource install --theme hicolor --novendor --size 512 $(SHARE_DIR)icons/attention.png feedindicator-attention" >> build/package/DEBIAN/postinst
+- @echo "xdg-icon-resource install --theme hicolor --novendor --size 128 --context apps $(SHARE_DIR)icons/logo-128x128.png feedindicator" >> build/package/DEBIAN/postinst
+- @echo "xdg-icon-resource install --theme hicolor --novendor --size 48 --context apps $(SHARE_DIR)icons/logo-48x48.png feedindicator" >> build/package/DEBIAN/postinst
+- @echo "xdg-desktop-menu install --novendor $(SHARE_DIR)feedindicator.desktop" >> build/package/DEBIAN/postinst
+- @chmod 755 build/package/DEBIAN/postinst
+-
+-
+-build/package/DEBIAN/prerm: build/package/DEBIAN
+- @echo "#!/bin/sh -e" > build/package/DEBIAN/prerm
+- @echo "xdg-icon-resource uninstall --theme hicolor --novendor --size 512 feedindicator-active" >> build/package/DEBIAN/prerm
+- @echo "xdg-icon-resource uninstall --theme hicolor --novendor --size 512 feedindicator-attention" >> build/package/DEBIAN/prerm
+- @echo "xdg-icon-resource uninstall --theme hicolor --novendor --size 128 --context apps feedindicator" >> build/package/DEBIAN/prerm
+- @echo "xdg-icon-resource uninstall --theme hicolor --novendor --size 48 --context apps feedindicator" >> build/package/DEBIAN/prerm
+- @echo "xdg-desktop-menu uninstall --novendor feedindicator.desktop" >> build/package/DEBIAN/prerm
+- @chmod 755 build/package/DEBIAN/prerm
+-
+-
+-build/copyright: build
+- @echo "Upstream-Name: feedindicator\nSource: https://github.com/jnphilipp/Feedindicator\n\nFiles: *\nCopyright: Copyright 2010-2017 Dave Gardner <eunbolt@gmail.com>, Michael Judge <email@clickopen.co.uk>, Nicolas Raoul <nicolas.raoul@gmail.com>, Nathanael Philipp (jnphilipp) <mail@jnphilipp.org>\nLicense: GPL-3+\n This program is free software; you can redistribute it\n and/or modify it under the terms of the GNU General Public\n License as published by the Free Software Foundation; either\n version 3 of the License, or (at your option) any later\n version.\n .\n This program is distributed in the hope that it will be\n useful, but WITHOUT ANY WARRANTY; without even the implied\n warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR\n PURPOSE. See the GNU General Public License for more\n details.\n .\n You should have received a copy of the GNU General Public\n License along with this package; if not, write to the Free\n Software Foundation, Inc., 51 Franklin St, Fifth Floor,\n Boston, MA 02110-1301 USA\n .\n On Debian systems, the full text of the GNU General Public\n License version 3 can be found in the file\n '/usr/share/common-licenses/GPL-3'." > build/copyright
+-
+-
+-build/changelog: build
+- @git log --oneline --decorate > build/changelog
+-
+-
+-build/feedindicator.1: build
+- @help2man -n "feedindicator - A RSS feed reader for the indicator area." feedindicator > build/feedindicator.1
+-
+-
+-install: bin/feedindicator bin/feedindicator.desktop build/copyright build/changelog build/feedindicator.1
+- @apt install python3 python3-gi python3-feedparser python3-configobj hicolor-icon-theme indicator-application xdg-utils
+- @xdg-icon-resource install --theme hicolor --novendor --size 512 icons/active.png feedindicator-active
+- @xdg-icon-resource install --theme hicolor --novendor --size 512 icons/attention.png feedindicator-attention
+- @xdg-icon-resource install --theme hicolor --novendor --size 128 --context apps icons/logo-128x128.png feedindicator
+- @xdg-icon-resource install --theme hicolor --novendor --size 48 --context apps icons/logo-48x48.png feedindicator
+- @xdg-desktop-menu install --novendor bin/feedindicator.desktop
+- @mkdir -p $(SHARE_DIR)
+- @cp -r feedindicator $(SHARE_DIR)
+- @install bin/feedindicator $(BIN_DIR)
+- @install feedindicator.bash-completion $(BASH_COMPLETION_DIR)
+- @cat build/feedindicator.1 | gzip -n9 > $(MAN_DIR)feedindicator.1.gz
+- @mkdir -p $(DOC_DIR)
+- @cat build/changelog | gzip -n9 > $(DOC_DIR)changelog.gz
+- @install build/copyright $(DOC_DIR)copyright
+- @echo "feedindicator install completed."
+-
+-
+-uninstall:
+- @rm -r $(SHARE_DIR)
+- @rm -r $(DOC_DIR)
+- @rm $(BIN_DIR)/feedindicator
+- @rm $(BASH_COMPLETION_DIR)feedindicator.bash-completion
+- @rm $(MAN_DIR)feedindicator.1.gz
+- @xdg-icon-resource uninstall --theme hicolor --novendor --size 512 feedindicator-active
+- @xdg-icon-resource uninstall --theme hicolor --novendor --size 512 feedindicator-attention
+- @xdg-icon-resource uninstall --theme hicolor --novendor --size 128 --context apps feedindicator
+- @xdg-icon-resource uninstall --theme hicolor --novendor --size 48 --context apps feedindicator
+- @xdg-desktop-menu uninstall --novendor feedindicator.desktop
+- @if [ -f ~/.config/feedindicator/feedindicator.desktop ]; then\
+- unlink ~/.config/feedindicator/feedindicator.desktop;\
+- fi
+- @if [ -d ~/.cache/feedindicator ]; then\
+- rm -r ~/.cache/feedindicator;\
+- fi
+- @if [ -d ~/.config/feedindicator ]; then\
+- rm -r ~/.config/feedindicator;\
+- fi
+- @if [ -d ~/.local/share/feedindicator ]; then\
+- rm -r ~/.local/share/feedindicator;\
+- fi
+- @echo "feedindicator uninstall completed."
+-
+-
+-deb: build/package/DEBIAN/control build/package/DEBIAN/postinst build/package/DEBIAN/prerm
+- fakeroot dpkg-deb -b build/package build/feedindicator.deb
+- lintian -Ivi build/feedindicator.deb
++install-python:
++ @find ./feedindicator -type f -exec install -Dm0644 "{}" "$(DESTDIR)$(SHARE_DIR)/""{}" \;
++
++
++install-wrapper: bin/feedindicator bin/feedindicator.desktop
++ @install -D bin/feedindicator "$(DESTDIR)$(BIN_DIR)/feedindicator"
++ @install -Dm0644 bin/feedindicator.desktop "$(DESTDIR)$(DESKTOP_DIR)/feedindicator.desktop"
++ @install -Dm0644 feedindicator.bash-completion "$(DESTDIR)$(BASH_COMPLETION_DIR)/feedindicator.bash-completion"
++
++
++install-icons:
++ @find ./icons -type f -exec install -Dm0644 "{}" "$(DESTDIR)$(SHARE_DIR)/""{}" \;
+
+
++install: install-python install-wrapper install-icons
++
++
++uninstall-python:
++ @rm -rf "$(DESTDIR)$(SHARE_DIR)/feedindicator"
++
++
++uninstall-wrapper:
++ @rm "$(DESTDIR)$(BIN_DIR)/feedindicator"
++ @rm "$(DESTDIR)$(DESKTOP_DIR)/feedindicator.desktop"
++ @rm "$(DESTDIR)$(BASH_COMPLETION_DIR)/feedindicator.bash-completion"
++
++
++uninstall-icons:
++ @rm -rf "$(DESTDIR)$(SHARE_DIR)/icons"
++
++
++uninstall: uninstall-python uninstall-wrapper uninstall-icons
++
+ clean:
+ @rm -rf ./bin
+- @rm -rf ./build
+ @find . -name __pycache__ -exec rm -rf {} \;
++
++.PHONY: install-python install-wrapper install-icons install uninstall-python uninstall-wrapper uninstall-icons uninstall clean