summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Scurtu2015-12-10 06:59:37 +0100
committerJason Scurtu2015-12-10 06:59:37 +0100
commit6b4581eb78fcc859b7f1af304bd5169fbf9b6fcd (patch)
tree0b7da4c4eef57403998d2278efff9f09225d4bc3
parente331e6b8ab17c35a18a4ac3e526158dd43e50eea (diff)
downloadaur-6b4581eb78fcc859b7f1af304bd5169fbf9b6fcd.tar.gz
Update to 1.4.2
-rw-r--r--.SRCINFO13
-rwxr-xr-xPKGBUILD16
-rw-r--r--patched_tmp_folder.patch60
3 files changed, 13 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 484695db0607..4e3b772e1c8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Dec 10 05:59:14 UTC 2015
pkgbase = feedreader
pkgdesc = A simple feedreader client for web services like Tiny Tiny RSS and in the future others.
- pkgver = 1.4.1
- pkgrel = 3
+ pkgver = 1.4.2
+ pkgrel = 1
url = https://launchpad.net/feedreader
install = feedreader.install
arch = i686
@@ -14,17 +16,14 @@ pkgbase = feedreader
depends = gtk3
depends = webkit2gtk
depends = libnotify
- depends = html2text-with-utf8
depends = libsoup
depends = libgee
depends = json-glib
depends = libsecret
provides = feedreader
conflicts = feedreader
- source = https://launchpad.net/feedreader/1.4/1.4.1/+download/FeedReader-1.4.1.tar.gz
- source = patched_tmp_folder.patch
- sha256sums = 1a0fcaf3d6bbd6bc75e3ef85e2d00e63ad85b150c566212de3b8f58decd0cfeb
- sha256sums = f00d16f3e0ed85171972c8c87fe8aec9058eb85273fd1523a50e40ead2f9cf17
+ source = https://launchpad.net/feedreader/1.4/1.4.2/+download/FeedReader-1.4.2.tar.gz
+ sha256sums = 5c866ccdbb5e642bf1e6a91370393fc44a688ee4da4f2bd4a693bf3491ada275
pkgname = feedreader
diff --git a/PKGBUILD b/PKGBUILD
index 37857c4f98e5..b817ca85caeb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Jason Scurtu (scujas) <jscurtu@gmail.com>
-# Original Maintainer: Marcin Tydelski <marcin.tydelski@gmail.com>
+# Contributor: Marcin Tydelski <marcin.tydelski@gmail.com>
# Contributor: Jan Lukas Gernert (JeanLuc) <https://launchpad.net/~eviltwin1>
pkgname=feedreader
-pkgver=1.4.1
-pkgrel=3
+pkgver=1.4.2
+pkgrel=1
pkgdesc='A simple feedreader client for web services like Tiny Tiny RSS and in the future others.'
arch=('i686' 'x86_64')
url='https://launchpad.net/feedreader'
license=('GPL3')
-depends=('sqlite3' 'gtk3' 'webkit2gtk' 'libnotify' 'html2text-with-utf8' 'libsoup' 'libgee' 'json-glib' 'libsecret')
+depends=('sqlite3' 'gtk3' 'webkit2gtk' 'libnotify' 'libsoup' 'libgee' 'json-glib' 'libsecret')
makedepends=('vala' 'gobject-introspection' 'cmake')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
install="${pkgname%-*}.install"
-source=('https://launchpad.net/feedreader/'${pkgver%.*}'/'${pkgver}'/+download/FeedReader-'${pkgver}'.tar.gz' patched_tmp_folder.patch)
-sha256sums=('1a0fcaf3d6bbd6bc75e3ef85e2d00e63ad85b150c566212de3b8f58decd0cfeb'
- 'f00d16f3e0ed85171972c8c87fe8aec9058eb85273fd1523a50e40ead2f9cf17')
+source=('https://launchpad.net/feedreader/'${pkgver%.*}'/'${pkgver}'/+download/FeedReader-'${pkgver}'.tar.gz')
+sha256sums=('5c866ccdbb5e642bf1e6a91370393fc44a688ee4da4f2bd4a693bf3491ada275')
pkgver() {
cd "${srcdir}"
@@ -28,9 +27,8 @@ build() {
if [[ -d "${srcdir}/build" ]]; then
rm -rf "${srcdir}/build"
fi
- patch -p1 -i $srcdir/patched_tmp_folder.patch
mkdir "${srcdir}/build" && cd "${srcdir}/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_WEBKIT_4=ON -DWITH_LIBUNITY=OFF -DWITH_VILISTEXTUM=OFF ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_WEBKIT_4=ON -DWITH_LIBUNITY=OFF ..
make
}
diff --git a/patched_tmp_folder.patch b/patched_tmp_folder.patch
deleted file mode 100644
index df7202b3abb1..000000000000
--- a/patched_tmp_folder.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -aur package.pristine/Changelog package.new/Changelog
---- package.pristine/Changelog 2015-11-13 02:42:18.000000000 +0100
-+++ package.new/Changelog 2015-11-20 11:56:00.412514000 +0100
-@@ -10,7 +10,7 @@
- - proper fullscreen mode for videos
- - support multiple share accounts of the same kind (e.g. two different pocket accounts)
- - fixed memory leaks
--- option to ignore unknown CA's
-+- option to ignore unknowns CA
- - updated GrabberConfig files to upstream from fivefilters
-
- 1.2:
-diff -aur package.pristine/src/Utils.vala package.new/src/Utils.vala
---- package.pristine/src/Utils.vala 2015-11-16 23:16:13.000000000 +0100
-+++ package.new/src/Utils.vala 2015-11-20 11:56:00.412514000 +0100
-@@ -33,7 +33,16 @@
- }
- else if(Article.getHTML() != "" && Article.getHTML() != null)
- {
-- string filename = GLib.Environment.get_tmp_dir() + "/" + "articleHtml.XXXXXX";
-+ string tmp_path = GLib.Environment.get_tmp_dir() + "/FeedReader/";
-+ var path = GLib.File.new_for_path(tmp_path);
-+ try{
-+ path.make_directory_with_parents();
-+ }
-+ catch(GLib.Error e){
-+ //logger.print(LogMessage.DEBUG, e.message);
-+ }
-+
-+ string filename = tmp_path + "articleHtml.XXXXXX";
- int outputfd = GLib.FileUtils.mkstemp(filename);
- try{
- GLib.FileUtils.set_contents(filename, Article.getHTML());
-@@ -120,7 +129,16 @@
- string title = "";
- doc->dump_memory_enc(out title);
-
-- string filename = GLib.Environment.get_tmp_dir() + "/" + "articleHtml.XXXXXX";
-+ string tmp_path = GLib.Environment.get_tmp_dir() + "/FeedReader/";
-+ var path = GLib.File.new_for_path(tmp_path);
-+ try{
-+ path.make_directory_with_parents();
-+ }
-+ catch(GLib.Error e){
-+ //logger.print(LogMessage.DEBUG, e.message);
-+ }
-+
-+ string filename = tmp_path + "articleHtml.XXXXXX";
- int outputfd = GLib.FileUtils.mkstemp(filename);
- try{
- GLib.FileUtils.set_contents(filename, title);
-@@ -154,7 +172,7 @@
- }
- #endif
-
-- return output.strip().replace("\n", "");
-+ return output.strip().replace("\n", " ");
- #else
- return old_title;
- #endif