summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-12-30 14:37:52 +0100
committerMichel Zou2017-12-30 14:37:52 +0100
commitcbe80f4a6877046fe62c8e3ef76c1414342cbc46 (patch)
tree9598901fd60dd76a62ec5b91f8fe3abb5fad3196
parent8b91f53a091d8e8615eb257597e2e95e3fed0297 (diff)
downloadaur-cbe80f4a6877046fe62c8e3ef76c1414342cbc46.tar.gz
petsc
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--d6891c9.patch26
3 files changed, 33 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ac678d6af42..3a858398bebe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Oct 3 11:36:20 UTC 2017
+# Sat Dec 30 13:37:52 UTC 2017
pkgbase = feelpp
pkgver = 0.103.2
pkgrel = 1
@@ -17,8 +17,10 @@ pkgbase = feelpp
depends = fftw
source = https://github.com/feelpp/feelpp/releases/download/v0.103.2/feelpp-0.103.2.tar.gz
source = fix-compilation.patch
+ source = d6891c9.patch
sha256sums = e083b6107cd78eafede8b051e478093b52a52c961748721241c874cfad2b9fe9
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = feelpp
diff --git a/PKGBUILD b/PKGBUILD
index a99e285693d6..f1d5ea58acd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,16 @@ url="https://github.com/feelpp"
license=('LGPL')
depends=('cln' 'mumps' 'slepc' 'petsc' 'gmsh' 'fftw')
makedepends=('cmake' 'eigen3')
-source=("https://github.com/feelpp/feelpp/releases/download/v${pkgver}/feelpp-${pkgver}.tar.gz" fix-compilation.patch)
-sha256sums=('e083b6107cd78eafede8b051e478093b52a52c961748721241c874cfad2b9fe9' SKIP)
+source=("https://github.com/feelpp/feelpp/releases/download/v${pkgver}/feelpp-${pkgver}.tar.gz" fix-compilation.patch d6891c9.patch)
+sha256sums=('e083b6107cd78eafede8b051e478093b52a52c961748721241c874cfad2b9fe9' SKIP SKIP)
prepare() {
cd $pkgbase-$pkgver
grep -lr 'COMMAND python' contrib/ginac|xargs sed -i "s|COMMAND python |COMMAND python2 |g"
patch -p1 -i "$srcdir"/fix-compilation.patch
+ patch -p1 -i "$srcdir"/d6891c9.patch
+
}
diff --git a/d6891c9.patch b/d6891c9.patch
new file mode 100644
index 000000000000..00a8e3da2ced
--- /dev/null
+++ b/d6891c9.patch
@@ -0,0 +1,26 @@
+From d6891c90f49d809cc3150d1b6e36c9d74df8f664 Mon Sep 17 00:00:00 2001
+From: Christophe Prud'homme <christophe.prudhomme@feelpp.org>
+Date: Fri, 6 Oct 2017 08:28:49 +0200
+Subject: [PATCH] petsc 3.8 seems to work fine with feel++ fixes #1068
+
+---
+ feel/feelalg/preconditionerpetsc.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/feel/feelalg/preconditionerpetsc.cpp b/feel/feelalg/preconditionerpetsc.cpp
+index f9d5287b7f..0ad7bf4f36 100644
+--- a/feel/feelalg/preconditionerpetsc.cpp
++++ b/feel/feelalg/preconditionerpetsc.cpp
+@@ -2954,8 +2954,12 @@ ConfigurePCGAMG::run( PC& pc )
+ this->check( PCGAMGSetProcEqLim( pc, M_procEqLim ) );
+ // Set max number of equations on coarse grids
+ this->check( PCGAMGSetCoarseEqLim( pc, M_coarseEqLim ) );
++#if PETSC_VERSION_GREATER_OR_EQUAL_THAN( 3,8,0 )
++ this->check( PCGAMGSetThresholdScale( pc, M_threshold ) );
++#else
+ // Relative threshold to use for dropping edges in aggregation graph
+ this->check( PCGAMGSetThreshold( pc, M_threshold ) );
++#endif
+ // not works!!(seems to be missing PetscObjectComposeFunction with this function)
+ //this->check( PCGAMGSetSymGraph( pc, ( M_setSymGraph )?PETSC_TRUE : PETSC_FALSE ) );
+ // Reuse prolongation operator