summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2017-09-18 13:56:16 +0200
committerMichel Zou2017-09-18 13:56:16 +0200
commitccd08b9b79fb71b2e6048fb8a34abfae4e9c2225 (patch)
treea8df79512f39b3a2591a938ced745420dd5f9376
parent9f67dc6aebf233fbeb40866a487ab013ec857e42 (diff)
downloadaur-ccd08b9b79fb71b2e6048fb8a34abfae4e9c2225.tar.gz
0.103.2
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD91
-rw-r--r--fix-compilation.patch40
3 files changed, 98 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3098489bb79a..a24fcf3b153e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Sep 18 11:56:16 UTC 2017
pkgbase = feelpp
- pkgver = 0.99.0
+ pkgver = 0.103.2
pkgrel = 1
url = https://github.com/feelpp
arch = i686
arch = x86_64
license = LGPL
- makedepends = cmake>=2.8.7
- depends = ann
+ makedepends = cmake
+ makedepends = eigen3
depends = cln
- depends = arpack
- depends = boost-libs
- depends = libxml2
- depends = gmsh
depends = mumps
+ depends = slepsc
depends = petsc
- optdepends = eigen3
- optdepends = fftw
- optdepends = metis
- optdepends = suitesparse
- optdepends = slepc
- optdepends = openturns
- optdepends = hdf5-openmpi
- optdepends = hdf5
- optdepends = gperftools
- source = https://github.com/feelpp/feelpp/releases/download/v0.99.0-final.1/feelpp-0.99.0-final.1.tar.gz
- md5sums = 47d49dde8af39a03c89fc0f64953db67
+ depends = gmsh
+ depends = fftw
+ source = https://github.com/feelpp/feelpp/releases/download/v0.103.2/feelpp-0.103.2.tar.gz
+ source = fix-compilation.patch
+ sha256sums = e083b6107cd78eafede8b051e478093b52a52c961748721241c874cfad2b9fe9
+ sha256sums = SKIP
pkgname = feelpp
- pkgdesc = Feel++ a library for finite element methods - libraries
-
-pkgname = feelpp-examples
- pkgdesc = Feel++ a library for finite element methods - examples
diff --git a/PKGBUILD b/PKGBUILD
index 20231dc32a2e..5eec52d6cfbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,62 @@
# Contributor: Guillaume DOLLÉ <dolle.guillaume at gmail.com>
-# Maintainer: George Eleftheriou <eleftg>
+# Contributor: George Eleftheriou <eleftg>
-pkgbase='feelpp'
pkgname='feelpp'
-true && pkgname=( 'feelpp' 'feelpp-examples' )
-pkgver=0.99.0
+pkgver=0.103.2
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/feelpp"
license=('LGPL')
-depends=('ann'
- 'cln'
- 'arpack'
- 'boost-libs'
- 'libxml2'
- 'gmsh'
- 'mumps'
- 'petsc' )
-makedepends=('cmake>=2.8.7')
-optdepends=( 'eigen3'
- 'fftw'
- 'metis'
- 'suitesparse'
- 'slepc'
- 'openturns'
- 'hdf5-openmpi'
- 'hdf5'
- 'gperftools' )
-
-source=($url/$pkgname/releases/download/v$pkgver-final.1/$pkgname-$pkgver-final.1.tar.gz)
+depends=('cln' 'mumps' 'slepsc' 'petsc' 'gmsh' 'fftw')
+makedepends=('cmake' 'eigen3')
+source=("https://github.com/feelpp/feelpp/releases/download/v${pkgver}/feelpp-${pkgver}.tar.gz" fix-compilation.patch)
+sha256sums=('e083b6107cd78eafede8b051e478093b52a52c961748721241c874cfad2b9fe9' SKIP)
prepare() {
- mkdir -p build
-}
+ cd $pkgbase-$pkgver
+ grep -lr 'COMMAND python' contrib/ginac|xargs sed -i "s|COMMAND python |COMMAND python2 |g"
-build() {
- cd build
- ../$pkgbase-$pkgver-final.1/configure -r --prefix=/usr
+ # need https://github.com/boostorg/qvm/commit/5209c985d843a52e428a497f9fb740e1741c86d4
+ curl -L https://github.com/boostorg/qvm/archive/master.zip -o qvm-master.zip
+ bsdtar -xf qvm-master.zip
+ cp -r qvm-master/include/boost .
+
+ patch -p1 -i "$srcdir"/fix-compilation.patch
}
-package_feelpp() {
- pkgdesc="Feel++ a library for finite element methods - libraries"
- cd $srcdir/build/contrib/ginac
- make DESTDIR="$pkgdir/" install
- cd $srcdir/build/feel/
- make DESTDIR="$pkgdir/" install
- cd $srcdir/build/cmake/modules
- make DESTDIR="$pkgdir/" install
- install -D -m 0644 $srcdir/$pkgbase-$pkgver-final.1/COPYING.md $pkgdir/usr/share/licenses/${pkgbase//pp}/COPYING.md
- install -D -m 0644 $srcdir/$pkgbase-$pkgver-final.1/ChangeLog $pkgdir/usr/share/doc/${pkgbase//pp}/ChangeLog
- install -D -m 0644 $srcdir/$pkgbase-$pkgver-final.1/README.md $pkgdir/usr/share/doc/${pkgbase//pp}/README.md
+
+
+build() {
+ cd $pkgbase-$pkgver
+ mkdir -p build && cd build
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_C_COMPILER=/usr/bin/clang \
+ -DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPETSC_DIR=/opt/petsc/linux-c-opt/ \
+ -DFEELPP_ENABLE_SYSTEM_EIGEN3=OFF \
+ -DFEELPP_ENABLE_OPENTURNS=OFF \
+ -DFEELPP_ENABLE_VTK=OFF \
+ -DFEELPP_ENABLE_QUICKSTART=OFF \
+ -DFEELPP_ENABLE_TOOLBOXES=OFF \
+ -DFEELPP_ENABLE_DOCUMENTATION=OFF \
+ -DFEELPP_ENABLE_BENCHMARKS=OFF \
+ -DFEELPP_ENABLE_APPLICATIONS=OFF \
+ -DFEELPP_ENABLE_TESTS=OFF \
+ -DFEELPP_ENABLE_RESEARCH=OFF \
+ -DFEELPP_USE_GMSH_PACKAGE=OFF \
+ -DBUILD_GUILE=OFF -DBUILD_MATLAB=OFF -DUSE_SWIG=OFF \
+ -DSUPPORT_OMP=OFF -DEIGEN_TEST_OPENMP=OFF \
+ ..
+ make feelpp -j1
+ make
}
-package_feelpp-examples() {
- pkgdesc="Feel++ a library for finite element methods - examples"
- cd $srcdir/build/doc/manual/tutorial
- make DESTDIR="$pkgdir/" install
+package() {
+ cd $pkgbase-$pkgver/build
+ make DESTDIR="$pkgdir/" install
}
-md5sums=('47d49dde8af39a03c89fc0f64953db67')
diff --git a/fix-compilation.patch b/fix-compilation.patch
new file mode 100644
index 000000000000..24e4c46e1de6
--- /dev/null
+++ b/fix-compilation.patch
@@ -0,0 +1,40 @@
+From b89da3af89255f6da77780d4679fd693489528c2 Mon Sep 17 00:00:00 2001
+From: Vincent Chabannes <vincent.chabannes@feelpp.org>
+Date: Sat, 22 Jul 2017 10:05:47 +0200
+Subject: [PATCH] fix compilation
+
+---
+ feel/feeldiscr/detail/element_impl.hpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/feel/feeldiscr/detail/element_impl.hpp b/feel/feeldiscr/detail/element_impl.hpp
+index 8e13ae543b..9266694f42 100644
+--- a/feel/feeldiscr/detail/element_impl.hpp
++++ b/feel/feeldiscr/detail/element_impl.hpp
+@@ -370,7 +370,7 @@ FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>::initSubElementView( mpl::tru
+
+ template<typename A0, typename A1, typename A2, typename A3, typename A4>
+ template<typename Y, typename Cont>
+-FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>&
++typename FunctionSpace<A0, A1, A2, A3, A4>::template Element<Y,Cont>&
+ FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>::operator=( Element<Y,Cont> const& __e )
+ {
+ if ( this != &__e )
+@@ -395,7 +395,7 @@ FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>::operator=( Element<Y,Cont> c
+ template<typename A0, typename A1, typename A2, typename A3, typename A4>
+ template<typename Y, typename Cont>
+ template<typename ContOtherType>
+-FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>&
++typename FunctionSpace<A0, A1, A2, A3, A4>::template Element<Y,Cont>&
+ FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>::operator=( Element<Y,ContOtherType> const& v )
+ {
+ if ( !M_functionspace )
+@@ -412,7 +412,7 @@ FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>::operator=( Element<Y,ContOth
+ template<typename A0, typename A1, typename A2, typename A3, typename A4>
+ template<typename Y, typename Cont>
+ template<typename VectorExpr>
+-FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>&
++typename FunctionSpace<A0, A1, A2, A3, A4>::template Element<Y,Cont>&
+ FunctionSpace<A0, A1, A2, A3, A4>::Element<Y,Cont>::operator=( VectorExpr const& __v )
+ {
+ super::operator=( __v );