summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2016-05-21 00:03:42 +0800
committerwenLiangcan2016-05-21 00:03:42 +0800
commit797464c71b1e73b5af0816d6c7c9876cab89ccd1 (patch)
treeef712a23339b5119a61e7b718faa2f3ddf99a895
downloadaur-797464c71b1e73b5af0816d6c7c9876cab89ccd1.tar.gz
feeluown-mpris2-plugin-git r7.ecac35e-1.
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD33
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..888b302a2659
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Fri May 20 16:03:32 UTC 2016
+pkgbase = feeluown-mpris2-plugin-git
+ pkgdesc = mpris dbus interface implementation for feeluown
+ pkgver = r7.ecac35e
+ pkgrel = 1
+ url = https://github.com/cosven/feeluown-mpris2-plugin
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = feeluown>=9.1a
+ depends = python-pyqt5
+ depends = qt5-multimedia
+ depends = python-dbus
+ optdepends = osd-lyrics-git: OSD lyric show
+ provides = feeluown-mpris2-plugin
+ conflicts = feeluown-mpris2-plugin
+ source = feeluown-mpris2-plugin::git+https://github.com/cosven/feeluown-mpris2-plugin.git
+ md5sums = SKIP
+
+pkgname = feeluown-mpris2-plugin-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b9c00bb21281
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,18 @@
+### https://raw.github.com/github/gitignore/b27b46b656d026ac295b3a47cf43e8af192472e2/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+feeluown-mpris2-plugin/
+
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fad03570f94b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+_pkgname=feeluown-mpris2-plugin
+pkgname="${_pkgname}-git"
+pkgver=r7.ecac35e
+pkgrel=1
+pkgdesc="mpris dbus interface implementation for feeluown"
+arch=("any")
+url="https://github.com/cosven/feeluown-mpris2-plugin"
+license=('MIT')
+depends=('feeluown>=9.1a' 'python-pyqt5' 'qt5-multimedia' 'python-dbus')
+optdepends=('osd-lyrics-git: OSD lyric show')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}"::"git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ _pyver=$(python3 -c "import sys; sys.stdout.write('%d.%d' % sys.version_info[0:2])")
+ find ./{*\.py,*\.xml} -type f -exec install -Dm644 {} \
+ "${pkgdir}/usr/lib/python${_pyver}/site-packages/feeluown/plugins/${_pkgname}/{}" \;
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}
+