summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeowkatee2024-01-14 17:25:48 +0800
committermeowkatee2024-01-14 17:25:48 +0800
commitc982d8f3a62eed9baad85cfaf9bf3489e50575fc (patch)
tree302c8b21ae59eb11ce75d23198bf59a6f83f370e
downloadaur-feeluown-qqmusic-git.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD35
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4eb88fdea684
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = feeluown-qqmusic-git
+ pkgdesc = feeluown qqmusic plugin
+ pkgver = r80.g4b21ae9
+ pkgrel = 1
+ url = https://github.com/feeluown/feeluown-qqmusic
+ arch = any
+ groups = feeluown-full
+ license = GPL3
+ makedepends = python-setuptools
+ depends = feeluown-git
+ depends = python-marshmallow
+ depends = python-requests
+ provides = feeluown-qqmusic
+ source = git+https://github.com/feeluown/feeluown-qqmusic.git
+ sha512sums = SKIP
+
+pkgname = feeluown-qqmusic-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b493c9fbc068
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/
+src/
+
+feeluown-qqmusic/
+
+*.tar.*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d76fe19ae865
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Meowkate
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Bruce Zhang <zttt183525594@gmail.com>
+
+pkgname=feeluown-qqmusic-git
+_pkgname=feeluown-qqmusic
+pkgver=r80.g4b21ae9
+pkgrel=1
+provides=('feeluown-qqmusic')
+conflicts=('feeluown-qqmusic')
+pkgdesc="feeluown qqmusic plugin"
+arch=('any')
+url="https://github.com/feeluown/${_pkgname}"
+license=('GPL3')
+depends=('feeluown-git' 'python-marshmallow' 'python-requests')
+makedepends=('python-setuptools')
+groups=('feeluown-full')
+source=("git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ echo "r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${_pkgname}
+ python setup.py build
+}
+
+package() {
+ cd ${_pkgname}
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+