summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-28 13:28:12 +0800
committerzxp198210052024-02-28 13:28:12 +0800
commitbadde3f9ab38ba10b84b354f318cfc3531561163 (patch)
treeb400d06383459fe3b8c99aa6b53482787b52ef2b
parentc2877026d7b48b2be8382d0655763a4707e8bbe1 (diff)
downloadaur-badde3f9ab38ba10b84b354f318cfc3531561163.tar.gz
fix errors
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--feidao.sh9
3 files changed, 13 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fad21733db37..ddcf320fa81e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,17 @@
pkgbase = feidao-bin
pkgdesc = 飞稻在线课程设计平台
pkgver = 1.0.0
- pkgrel = 5
+ pkgrel = 6
url = https://www.fei-dao.com
arch = x86_64
- license = custom
- makedepends = squashfuse
+ license = LicenseRef-custom
depends = hicolor-icon-theme
depends = electron13
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk2
provides = feidao=1.0.0
conflicts = feidao
source = feidao-1.0.0.AppImage::https://oss.fei-dao.com/resources/application/linux/feidao_latest.AppImage
source = feidao.sh
sha256sums = 2a5f5919ebc8c7ef8ebd232758852c87dd0b165208dc46a501ce3cefdd23ded7
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = feidao-bin
diff --git a/PKGBUILD b/PKGBUILD
index b8ce6126e9c3..d13ccf058703 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,27 @@
pkgname=feidao-bin
pkgver=1.0.0
_electronversion=13
-pkgrel=5
+pkgrel=6
pkgdesc="飞稻在线课程设计平台"
arch=("x86_64")
url="https://www.fei-dao.com"
-license=('custom')
+license=('LicenseRef-custom')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
depends=(
'hicolor-icon-theme'
"electron${_electronversion}"
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
-)
-makedepends=(
- 'squashfuse'
)
-provides=("${pkgname%-bin}=${pkgver}")
-conflicts=("${pkgname%-bin}")
source=(
"${pkgname%-bin}-${pkgver}.AppImage::https://oss.fei-dao.com/resources/application/linux/${pkgname%-bin}_latest.AppImage"
"${pkgname%-bin}.sh"
)
sha256sums=('2a5f5919ebc8c7ef8ebd232758852c87dd0b165208dc46a501ce3cefdd23ded7'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/feidao.sh b/feidao.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/feidao.sh
+++ b/feidao.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file