summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-19 16:50:37 +0800
committerzxp198210052024-01-19 16:50:37 +0800
commitc2877026d7b48b2be8382d0655763a4707e8bbe1 (patch)
tree7a03fe993c3e471c89ff7c33fc3295cf2fb87bd8
parent565095858bba0abe02fedd6b604e16bd5c40d8da (diff)
downloadaur-c2877026d7b48b2be8382d0655763a4707e8bbe1.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--feidao.sh13
3 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a8d46f2c8a0..fad21733db37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = feidao-bin
pkgdesc = 飞稻在线课程设计平台
pkgver = 1.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://www.fei-dao.com
arch = x86_64
license = custom
makedepends = squashfuse
depends = hicolor-icon-theme
depends = electron13
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
provides = feidao=1.0.0
conflicts = feidao
source = feidao-1.0.0.AppImage::https://oss.fei-dao.com/resources/application/linux/feidao_latest.AppImage
source = feidao.sh
sha256sums = 2a5f5919ebc8c7ef8ebd232758852c87dd0b165208dc46a501ce3cefdd23ded7
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
pkgname = feidao-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1fec57a6ef73..b8ce6126e9c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=feidao-bin
pkgver=1.0.0
_electronversion=13
-pkgrel=4
+pkgrel=5
pkgdesc="飞稻在线课程设计平台"
arch=("x86_64")
url="https://www.fei-dao.com"
@@ -10,12 +10,9 @@ license=('custom')
depends=(
'hicolor-icon-theme'
"electron${_electronversion}"
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
@@ -27,7 +24,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('2a5f5919ebc8c7ef8ebd232758852c87dd0b165208dc46a501ce3cefdd23ded7'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -35,7 +32,7 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/feidao.sh b/feidao.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/feidao.sh
+++ b/feidao.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file