summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWoodenman2024-03-18 20:37:03 +0800
committerWoodenman2024-03-18 20:37:03 +0800
commitfe0ee189b320fbbb01f1549ee674d4f41b37ef6d (patch)
treecc3b52dbd2c28453b2c705b35b8b59b80cf12192
parentbadde3f9ab38ba10b84b354f318cfc3531561163 (diff)
downloadaur-fe0ee189b320fbbb01f1549ee674d4f41b37ef6d.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddcf320fa81e..cdf5a4bdfa0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = feidao-bin
pkgdesc = 飞稻在线课程设计平台
pkgver = 1.0.0
- pkgrel = 6
+ pkgrel = 7
url = https://www.fei-dao.com
arch = x86_64
license = LicenseRef-custom
- depends = hicolor-icon-theme
- depends = electron13
+ makedepends = fuse2
+ depends = electron13-bin
provides = feidao=1.0.0
conflicts = feidao
source = feidao-1.0.0.AppImage::https://oss.fei-dao.com/resources/application/linux/feidao_latest.AppImage
source = feidao.sh
sha256sums = 2a5f5919ebc8c7ef8ebd232758852c87dd0b165208dc46a501ce3cefdd23ded7
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = feidao-bin
diff --git a/PKGBUILD b/PKGBUILD
index d13ccf058703..faa6236b117d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=feidao-bin
pkgver=1.0.0
_electronversion=13
-pkgrel=6
+pkgrel=7
pkgdesc="飞稻在线课程设计平台"
arch=("x86_64")
url="https://www.fei-dao.com"
@@ -10,19 +10,22 @@ license=('LicenseRef-custom')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- 'hicolor-icon-theme'
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
+)
+makedepends=(
+ 'fuse2'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::https://oss.fei-dao.com/resources/application/linux/${pkgname%-bin}_latest.AppImage"
"${pkgname%-bin}.sh"
)
sha256sums=('2a5f5919ebc8c7ef8ebd232758852c87dd0b165208dc46a501ce3cefdd23ded7'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null