summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2022-06-13 12:01:55 +0800
committerAllen Zhong2022-06-13 12:01:55 +0800
commit3decb4f5e86915a0e8d7b0f679c0337ef306edd0 (patch)
treeaedf090626796830a771b700f1c87d29942ef773
parentc96e90735fd4bdc1207239dbe97a5c29fe1e2dcc (diff)
downloadaur-3decb4f5e86915a0e8d7b0f679c0337ef306edd0.tar.gz
bump 5.9.18-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 042ec7dcfe4f..b9e87493fce6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = feishu-bin
pkgdesc = Linux client of Feishu (Lark) from Bytedance.
- pkgver = 5.4.13
+ pkgver = 5.9.18
pkgrel = 1
url = https://www.feishu.cn/
install = feishu-bin.install
@@ -16,7 +16,7 @@ pkgbase = feishu-bin
replaces = bytedance-feishu-stable-bin
options = !strip
options = !emptydirs
- source = https://sf3-cn.feishucdn.com/obj/ee-appcenter/e734d9e40e6a/Feishu-linux_x64-5.4.13.deb
- sha256sums = 26dddc20e13f733640dbf8669f4dc24f8c098d5db71f9f86ffe33546a68a5986
+ source = https://sf3-cn.feishucdn.com/obj/ee-appcenter/5db94058d7ad/Feishu-linux_x64-5.9.18.deb
+ sha256sums = ffb29b5a184b025d4e4ea468a8f684a7067ab5bfd45867abc370e59be63892c7
pkgname = feishu-bin
diff --git a/PKGBUILD b/PKGBUILD
index de07fc55e3f5..38bceea76810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Maintainer: Allen Zhong <allen@moe.cat>
# Contributor: Feishu Linux Team <contact@feishu.cn>
pkgname=feishu-bin
-pkgver=5.4.13
+pkgver=5.9.18
#_pkgrel=24
-_pkgtyp=dev
-_pkghash=e734d9e40e6a
+_pkgtyp=stable
+_pkghash=5db94058d7ad
pkgrel=1
pkgdesc="Linux client of Feishu (Lark) from Bytedance."
arch=('x86_64')
@@ -18,7 +18,7 @@ provides=('bytedance-feishu' 'feishu')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source=("https://sf3-cn.feishucdn.com/obj/ee-appcenter/${_pkghash}/Feishu-linux_x64-${pkgver}.deb")
-sha256sums=('26dddc20e13f733640dbf8669f4dc24f8c098d5db71f9f86ffe33546a68a5986')
+sha256sums=('ffb29b5a184b025d4e4ea468a8f684a7067ab5bfd45867abc370e59be63892c7')
package(){
# Extract package data
@@ -28,12 +28,15 @@ package(){
cd "${pkgdir}"
ln -s bytedance-feishu-${_pkgtyp} usr/bin/feishu
sed -i "s/bytedance-feishu-${_pkgtyp}/feishu/g" "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
+ sed -i "s/bytedance-feishu/feishu/g" "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
+ sed -i 's/StartupNotify=true/StartupNotify=true\nStartupWMClass=bytedance-feishu/g' "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
sed -i "s/bytedance-feishu/feishu/g" "${pkgdir}/usr/share/menu/bytedance-feishu.menu"
sed -i 's/bytedance-feishu/feishu/g' "${pkgdir}/usr/share/appdata/bytedance-feishu.appdata.xml"
+ sed -i 's/bytedance-feishu/feishu/g' "${pkgdir}/opt/bytedance/feishu/bytedance-feishu"
mv "${pkgdir}"/usr/share/menu/{bytedance-,}feishu.menu
mv "${pkgdir}"/usr/share/applications/{bytedance-,}feishu.desktop
mv "${pkgdir}"/usr/share/appdata/{bytedance-,}feishu.appdata.xml
- mv "${pkgdir}"/usr/share/man/man1/{bytedance-,}feishu.1.gz
+ mv "${pkgdir}"/usr/share/man/man1/{bytedance-feishu-${_pkgtyp},feishu}.1.gz
mv "${pkgdir}"/usr/share/doc/{bytedance-feishu-${_pkgtyp},feishu}
# Fix directory permissions