summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsgerwk2020-07-15 08:26:40 +0200
committersgerwk2020-07-15 08:26:40 +0200
commit4427d9c06f7988e106a2dc6eb8955dc49351b7f6 (patch)
tree503729e1af5b1f1c206e14ccf46e9e2e60e4d5ac
parent1700cfb464c986a64e201e6bb8faaf816f029fee (diff)
downloadaur-4427d9c06f7988e106a2dc6eb8955dc49351b7f6.tar.gz
enable features
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ee1169f0117..1c70ebdcc1f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,7 @@ pkgbase = felinks
depends = libidn
depends = expat
depends = ncurses
+ depends = lua51
conficts = elinks
conficts = elinks-git
source = git+https://github.com/rkd77/felinks#tag=v0.13.3
diff --git a/PKGBUILD b/PKGBUILD
index 7b15e904b488..6e74350bb8b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@ pkgrel=1
pkgdesc="text browser"
license=(GPL2)
arch=('x86_64' 'i686')
-depends=(tre brotli libx11 openssl gpm zstd libidn expat ncurses)
-conficts=(elinks elinks-git)
+depends=(tre brotli libx11 openssl gpm zstd libidn expat ncurses lua51)
makedepends=('gcc' 'make')
+conficts=(elinks elinks-git)
url="http://github.com/rkd77/felinks"
source=(git+https://github.com/rkd77/felinks#tag=v$pkgver)
sha256sums=('SKIP')
@@ -15,7 +15,8 @@ sha256sums=('SKIP')
build() {
cd $startdir/src/$pkgname
./autogen.sh
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc \
+ --with-luapkg=lua51 --enable-cgi --enable-leds --enable-bittorrent
make || return 1
}