summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprintfn2020-09-28 07:27:06 +0000
committerprintfn2020-09-28 07:27:06 +0000
commitbe2240f5d16a905dbbf38b94423a2b98002e23aa (patch)
tree706cd9544755c1ac0a2a527481ccfd0e13433523
downloadaur-be2240f5d16a905dbbf38b94423a2b98002e23aa.tar.gz
Add fend-0.1.4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..168d05098521
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fend
+ pkgdesc = Arbitrary-precision unit-aware calculator
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/printfn/fend-rs
+ arch = x86_64
+ license = GPL3
+ license = custom:MIT
+ makedepends = rust>=1.46.0
+ depends = gcc-libs
+ source = fend-0.1.4.tar.gz::https://static.crates.io/crates/fend/fend-0.1.4.crate
+ sha512sums = 38fcfce4b5a67c5eb00bfd2fda7db03584a5e79390c31f7a92e5a3a7b576b922b4541ba9ba3818746ea28a0878c45b93437650e8d41feb388959c7972eafd3f3
+
+pkgname = fend
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f388488c589
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: printfn <printfn@users.noreply.github.com>
+pkgname=fend
+pkgver=0.1.4
+pkgrel=1
+epoch=
+pkgdesc="Arbitrary-precision unit-aware calculator"
+arch=('x86_64')
+url="https://github.com/printfn/fend-rs"
+license=('GPL3' 'custom:MIT')
+groups=()
+depends=('gcc-libs')
+makedepends=('rust>=1.46.0')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
+noextract=()
+sha512sums=("38fcfce4b5a67c5eb00bfd2fda7db03584a5e79390c31f7a92e5a3a7b576b922b4541ba9ba3818746ea28a0878c45b93437650e8d41feb388959c7972eafd3f3")
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked --target-dir=target
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+