summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph2019-09-25 15:30:33 +0200
committerChristoph2019-09-25 15:30:33 +0200
commit996f09209203a400567811e2b69d477d2dcbaea0 (patch)
treeee21a069d84d96ce8b25141052c7e0dde85c2b93
downloadaur-996f09209203a400567811e2b69d477d2dcbaea0.tar.gz
Ferdi stable initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD76
-rw-r--r--ferdi.desktop12
-rw-r--r--ferdi.sh3
4 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2affafb56ca9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ferdi
+ pkgdesc = Ferdi is a messaging browser that allows you to combine your favorite messaging services into one application.
+ pkgver = 5.3.3
+ pkgrel = 1
+ url = https://getferdi.com/
+ arch = x86_64
+ arch = i686
+ license = Apache
+ makedepends = expac
+ makedepends = git
+ makedepends = npm
+ makedepends = python2
+ depends = electron4
+ conflicts = ferdi-git
+ source = git+https://github.com/getferdi/ferdi#tag=v5.3.3
+ source = ferdi.desktop
+ source = ferdi.sh
+ sha512sums = SKIP
+ sha512sums = e09649fd9daa2b8391ae7a60e3f81c056269d71afc22fe891c89611eb6c927a2b3b9e0bc69aeb859d75bb8bc7a104197d9f956345bd227a5ac995ef93a2bb68c
+ sha512sums = 54586148db4c1df88099485beae49f7a069fdcbca35ebb4fb3df3a15963f295712d8d9dfeddb1402b3676447eb2e9ea07b28808b0c611fca72617e32777ea7e8
+
+pkgname = ferdi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3601a066f23c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Christoph Mohr <christoph.mohr@gmail.com>
+# Contributor: Giovanni 'ItachiSan' Santini <giovannisantini93@yahoo.it>
+# Contributor: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
+# Contributor: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
+
+pkgname=ferdi
+_pkgver=5.3.3
+pkgver=${_pkgver//-/_}
+pkgrel=1
+pkgdesc='Ferdi is a messaging browser that allows you to combine your favorite messaging services into one application.'
+arch=(x86_64 i686)
+url='https://getferdi.com/'
+license=(Apache)
+depends=(electron4)
+conflicts=('ferdi-git')
+makedepends=(expac git npm python2)
+source=("git+https://github.com/getferdi/$pkgname#tag=v$_pkgver"
+ 'ferdi.desktop'
+ 'ferdi.sh')
+sha512sums=('SKIP'
+ 'e09649fd9daa2b8391ae7a60e3f81c056269d71afc22fe891c89611eb6c927a2b3b9e0bc69aeb859d75bb8bc7a104197d9f956345bd227a5ac995ef93a2bb68c'
+ '54586148db4c1df88099485beae49f7a069fdcbca35ebb4fb3df3a15963f295712d8d9dfeddb1402b3676447eb2e9ea07b28808b0c611fca72617e32777ea7e8')
+
+prepare() {
+ # Prepare Python 2 for later
+ mkdir python2_path
+ ln -s `which python2` python2_path/python
+
+ # Small patching
+ cd ferdi
+
+ # Prevent ferdi from being launched in dev mode
+ sed -i "s|export const isDevMode = .*|export const isDevMode = false;|g" \
+ src/environment.js
+ sed -i "s|import isDevMode from 'electron-is-dev'|export const isDevMode = false|g" \
+ src/index.js
+
+ # Adjust the electron version to use when building
+ electron_version="`expac %v electron4 | cut -d'-' -f1`"
+ sed -i "s|\(\s\+\"electron4\":\).*,|\1 \"$electron_version\",|" package.json
+
+ # Adjust node-sass version to avoid build issues
+ npm install "node-sass@4.12.0"
+
+ # Prepare the packages for building
+}
+
+build() {
+ cd ferdi
+
+ # Better configuration for npm cache and calling installed binaries
+ export npm_config_cache="$srcdir"/npm_cache
+ export PATH="$srcdir/ferdi/node_modules/.bin:$srcdir/python2_path:$PATH"
+
+ npm install lerna
+ lerna bootstrap
+
+ gulp build
+ electron-builder --linux dir
+}
+
+package() {
+ cd ferdi
+
+ # Install the .asar files
+ install -dm 755 "$pkgdir"/usr/lib/ferdi
+ cp -r --no-preserve=ownership --preserve=mode out/linux-unpacked/resources "$pkgdir"/usr/lib/ferdi/
+
+ # Install icon
+ install -Dm 644 "$srcdir"/ferdi.desktop "$pkgdir"/usr/share/applications/ferdi.desktop
+ install -Dm 644 build-helpers/images/icon.png "$pkgdir"/usr/share/icons/ferdi.png
+
+ # Install run script
+ install -Dm 755 "$srcdir"/ferdi.sh "$pkgdir"/usr/bin/ferdi
+}
+
diff --git a/ferdi.desktop b/ferdi.desktop
new file mode 100644
index 000000000000..d7b327854eec
--- /dev/null
+++ b/ferdi.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=Ferdi
+GenericName=Internet Messenger
+Comment=A free messaging app for services like WhatsApp, Slack, Messenger and many more.
+Icon=ferdi
+TryExec=/usr/bin/ferdi
+Exec=/usr/bin/ferdi %U
+Terminal=false
+Categories=Network;InstantMessaging;
+Name[de_DE]=Ferdi
diff --git a/ferdi.sh b/ferdi.sh
new file mode 100644
index 000000000000..3e1eb77c0f79
--- /dev/null
+++ b/ferdi.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+electron4 /usr/lib/ferdi/resources/app.asar "$@"