summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph2019-09-26 13:25:20 +0200
committerChristoph2019-09-26 13:25:20 +0200
commit49c370bdefe6d906c6013863cb240acb7bc1f5a7 (patch)
treef925618629578542ce25f1d040bb666db3d8938f
parent634a1cb4bf35c912ce78065522a96696dd1eec22 (diff)
downloadaur-49c370bdefe6d906c6013863cb240acb7bc1f5a7.tar.gz
still broken, sorry
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 521be86e7800..137a1ec24141 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = ferdi-git
pkgdesc = Free messaging app for services like WhatsApp, Slack, Messenger and many more. fork removing the non-skippable app delay frequently inviting you to buy a licence
pkgver = 5.3.4
pkgrel = 3
- url = https://github.com/getferdi/ferdi
+ url = https://getferdi.com/
arch = x86_64
arch = i686
license = Apache
@@ -12,7 +12,7 @@ pkgbase = ferdi-git
makedepends = python2
depends = electron4
conflicts = ferdi
- source = git+https://github.com/kytwb/ferdi/
+ source = git://github.com/getferdi/ferdi.git
source = ferdi.desktop
source = ferdi.sh
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1100e9dba7c7..9b760b6bf926 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,12 @@ pkgver=${_pkgver//-/_}
pkgrel=3
pkgdesc='Free messaging app for services like WhatsApp, Slack, Messenger and many more. fork removing the non-skippable app delay frequently inviting you to buy a licence'
arch=(x86_64 i686)
-url='https://github.com/getferdi/ferdi'
+url='https://getferdi.com/'
license=(Apache)
conflicts=('ferdi')
depends=(electron4)
makedepends=(expac git npm python2)
-source=("git+https://github.com/kytwb/ferdi/"
+source=('git://github.com/getferdi/ferdi.git'
'ferdi.desktop'
'ferdi.sh')
sha512sums=('SKIP'
@@ -28,6 +28,8 @@ prepare() {
# Small patching
cd ferdi
+ git submodule update --init --recursive
+
# Prevent ferdi from being launched in dev mode
sed -i "s|export const isDevMode = .*|export const isDevMode = false;|g" \
@@ -41,7 +43,6 @@ prepare() {
# Adjust node-sass version to avoid build issues
npm install "node-sass@4.12.0"
-
# Prepare the packages for building
}
@@ -52,6 +53,7 @@ build() {
export npm_config_cache="$srcdir"/npm_cache
export PATH="$srcdir/ferdi/node_modules/.bin:$srcdir/python2_path:$PATH"
+
npm install lerna
lerna bootstrap
@@ -61,7 +63,6 @@ build() {
package() {
cd ferdi
-
# Install the .asar files
install -dm 755 "$pkgdir"/usr/lib/ferdi
cp -r --no-preserve=ownership --preserve=mode out/linux-unpacked/resources "$pkgdir"/usr/lib/ferdi/