summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-04-23 21:27:07 +0200
committerDaniel Peukert2020-04-23 21:27:07 +0200
commit757231a39b4cdbe1f99470829bc3e64996fb36c7 (patch)
tree0abca2f6f45cf421d00f8e94f8dfbae12b71e7d0
parentff7e46e94f889e6b8f74ac525669974608ba5118 (diff)
downloadaur-757231a39b4cdbe1f99470829bc3e64996fb36c7.tar.gz
Unify git pkgver functions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef3750a3cd46..9a71acc8a7f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ferdi-git
pkgdesc = A messaging browser that allows you to combine your favorite messaging services into one application - git version
- pkgver = 5.4.4.beta.2.r40.gd269249a
- pkgrel = 2
+ pkgver = 5.5.0.gm.2.r0.g3a449c20
+ pkgrel = 1
url = https://getferdi.com
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 1d977c94083a..26ae6b9637a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
_pkgname='ferdi'
pkgname="$_pkgname-git"
-pkgver='5.4.4.beta.2.r40.gd269249a'
-pkgrel='2'
+pkgver='5.5.0.gm.2.r0.g3a449c20'
+pkgrel='1'
pkgdesc='A messaging browser that allows you to combine your favorite messaging services into one application - git version'
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://get$_pkgname.com"
@@ -58,7 +58,7 @@ prepare() {
pkgver() {
cd "$srcdir/$_sourcedirectory/"
- git describe --long --tags | sed -e 's/^v//' -e 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed -e 's/^v//' -e 's/-\([^-]*-g[^-]*\)$/-r\1/' -e 's/-/./g'
}
build() {