summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Roijakkers2022-04-25 08:12:14 +0200
committerCedric Roijakkers2022-04-25 08:18:28 +0200
commit5339a8c4c7af79389e1034dad50d0cdc466a354c (patch)
tree863e05de194ba57d4acf09d9a01eaf25546d54d9
parent99ae68b97fecf78afe3cbd68f8081e67f4502325 (diff)
downloadaur-5339a8c4c7af79389e1034dad50d0cdc466a354c.tar.gz
Updated to 6.0.0.nightly.10.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rwxr-xr-xupdate.sh8
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 366508554fa1..d26fef4e8fe1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ferdium
pkgdesc = A messaging browser that allows you to combine your favorite messaging services into one application (git build from latest release).
- pkgver = 6.0.0.nightly.7
+ pkgver = 6.0.0.nightly.10
pkgrel = 1
url = https://ferdium.org/
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = ferdium
depends = libxkbfile
provides = ferdium
conflicts = ferdium
- source = ferdium::git+https://github.com/ferdium/ferdium-app#tag=v6.0.0-nightly.7
+ source = ferdium::git+https://github.com/ferdium/ferdium-app#tag=v6.0.0-nightly.10
source = ferdium-recipes::git+https://github.com/ferdium/ferdium-recipes#branch=master
source = fix-autostart-path.diff
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e30d44cd3a1b..6b7395bc7e5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
_pkgname='ferdium'
pkgname="ferdium"
-pkgver=6.0.0.nightly.7
+pkgver=6.0.0.nightly.10
pkgrel=1
pkgdesc='A messaging browser that allows you to combine your favorite messaging services into one application (git build from latest release).'
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://ferdium.org/"
license=('Apache')
depends=('libxkbfile')
-apptag="v6.0.0-nightly.7"
+apptag="v6.0.0-nightly.10"
recipiesbranch="master"
-nodejsversion='18.0.0'
+nodejsversion='16.14.2'
makedepends=('nvm' 'git' 'python' 'jq')
provides=("$_pkgname")
conflicts=("$_pkgname")
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..fb90a8a38f29
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,8 @@
+#!/usr/bin/env bash
+
+set -e
+
+makepkg
+makepkg --printsrcinfo > .SRCINFO
+newversion=$(grep pkgver .SRCINFO | awk -F= '{print $2}' | sed -e 's/ //g')
+git commit -am "Updated to ${newversion}."