diff options
author | Cedric Roijakkers | 2022-04-25 08:12:14 +0200 |
---|---|---|
committer | Cedric Roijakkers | 2022-04-25 08:18:28 +0200 |
commit | 5339a8c4c7af79389e1034dad50d0cdc466a354c (patch) | |
tree | 863e05de194ba57d4acf09d9a01eaf25546d54d9 | |
parent | 99ae68b97fecf78afe3cbd68f8081e67f4502325 (diff) | |
download | aur-5339a8c4c7af79389e1034dad50d0cdc466a354c.tar.gz |
Updated to 6.0.0.nightly.10.
-rw-r--r-- | .SRCINFO | 4 | ||||
-rw-r--r-- | PKGBUILD | 6 | ||||
-rwxr-xr-x | update.sh | 8 |
3 files changed, 13 insertions, 5 deletions
@@ -1,6 +1,6 @@ pkgbase = ferdium pkgdesc = A messaging browser that allows you to combine your favorite messaging services into one application (git build from latest release). - pkgver = 6.0.0.nightly.7 + pkgver = 6.0.0.nightly.10 pkgrel = 1 url = https://ferdium.org/ arch = x86_64 @@ -15,7 +15,7 @@ pkgbase = ferdium depends = libxkbfile provides = ferdium conflicts = ferdium - source = ferdium::git+https://github.com/ferdium/ferdium-app#tag=v6.0.0-nightly.7 + source = ferdium::git+https://github.com/ferdium/ferdium-app#tag=v6.0.0-nightly.10 source = ferdium-recipes::git+https://github.com/ferdium/ferdium-recipes#branch=master source = fix-autostart-path.diff sha512sums = SKIP @@ -3,16 +3,16 @@ _pkgname='ferdium' pkgname="ferdium" -pkgver=6.0.0.nightly.7 +pkgver=6.0.0.nightly.10 pkgrel=1 pkgdesc='A messaging browser that allows you to combine your favorite messaging services into one application (git build from latest release).' arch=('x86_64' 'i686' 'armv7h' 'aarch64') url="https://ferdium.org/" license=('Apache') depends=('libxkbfile') -apptag="v6.0.0-nightly.7" +apptag="v6.0.0-nightly.10" recipiesbranch="master" -nodejsversion='18.0.0' +nodejsversion='16.14.2' makedepends=('nvm' 'git' 'python' 'jq') provides=("$_pkgname") conflicts=("$_pkgname") diff --git a/update.sh b/update.sh new file mode 100755 index 000000000000..fb90a8a38f29 --- /dev/null +++ b/update.sh @@ -0,0 +1,8 @@ +#!/usr/bin/env bash + +set -e + +makepkg +makepkg --printsrcinfo > .SRCINFO +newversion=$(grep pkgver .SRCINFO | awk -F= '{print $2}' | sed -e 's/ //g') +git commit -am "Updated to ${newversion}." |