summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Roijakkers2024-03-11 09:01:25 +0100
committerCedric Roijakkers2024-03-11 09:01:25 +0100
commitadf472501fcd89d96e9c846d151cb8aa9cf7f4b7 (patch)
tree77dc87dd1a6a04f296e03b4bff0a82cff229c738
parent5e3a088ffcc4030bfa937cd1a0ce033fad9a0528 (diff)
downloadaur-adf472501fcd89d96e9c846d151cb8aa9cf7f4b7.tar.gz
Updated Electron dependency to 29.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b221db8ea8ea..1f98f8e94709 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ferdium-bin
pkgdesc = A messaging browser that allows you to combine your favorite messaging services into one application (binary release).
pkgver = 6.7.1
- pkgrel = 2
+ pkgrel = 1
url = https://ferdium.org
arch = x86_64
arch = armv7l
@@ -24,7 +24,7 @@ pkgbase = ferdium-bin
depends = minizip
depends = re2
depends = snappy
- depends = electron27
+ depends = electron29
provides = ferdium
conflicts = ferdium
conflicts = ferdium-nightly-bin
@@ -34,11 +34,11 @@ pkgbase = ferdium-bin
conflicts = ferdium-git
conflicts = ferdium-electron
options = !strip
- source_x86_64 = ferdium-bin-6.7.1-2-amd64.zip::https://github.com/ferdium/ferdium-app/releases/download/v6.7.1/Ferdium-linux-6.7.1-amd64.deb
+ source_x86_64 = ferdium-bin-6.7.1-1-amd64.zip::https://github.com/ferdium/ferdium-app/releases/download/v6.7.1/Ferdium-linux-6.7.1-amd64.deb
sha512sums_x86_64 = 7bcba5bf20d85c45cb3e2409e788b77aac39b24b9f66f1c5d9c02b99727a193897db389db25ea02d763490cdd36592a5d92bcc714993619b9b0115bd2e14760e
- source_armv7l = ferdium-bin-6.7.1-2-armv7l.zip::https://github.com/ferdium/ferdium-app/releases/download/v6.7.1/Ferdium-linux-6.7.1-armv7l.deb
+ source_armv7l = ferdium-bin-6.7.1-1-armv7l.zip::https://github.com/ferdium/ferdium-app/releases/download/v6.7.1/Ferdium-linux-6.7.1-armv7l.deb
sha512sums_armv7l = 28a2968c5f4d56b2f346bd5eba85da6184748eed44123665541ba7166643e6c7fb18274f78fff87ed1907209b53ade2f9eda78e3d887c4ac88e3438ae2a10e63
- source_aarch64 = ferdium-bin-6.7.1-2-arm64.zip::https://github.com/ferdium/ferdium-app/releases/download/v6.7.1/Ferdium-linux-6.7.1-arm64.deb
+ source_aarch64 = ferdium-bin-6.7.1-1-arm64.zip::https://github.com/ferdium/ferdium-app/releases/download/v6.7.1/Ferdium-linux-6.7.1-arm64.deb
sha512sums_aarch64 = 3eb82e35463e088cec1a4e76df2ff788e5ec5aea9d3199d8ad2f29e8a21e207de14d6e1f0a428d435167c550df182e7b21972aa0fbc1558a76441c9b467dd71d
pkgname = ferdium-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3776accfdd5c..c6d81a07a599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
_pkgname='ferdium'
pkgname="$_pkgname-bin"
-_electron='electron27'
-_electronpackage='electron27'
+_electron='electron29'
+_electronpackage='electron29'
pkgverorg='6.7.1'
pkgver='6.7.1'
-pkgrel='2'
+pkgrel='1'
pkgdesc='A messaging browser that allows you to combine your favorite messaging services into one application (binary release).'
arch=('x86_64' 'armv7l' 'aarch64')
url="https://$_pkgname.org"
@@ -67,6 +67,20 @@ EOF
install -Dm644 "usr/share/icons/hicolor/${_size}x${_size}/apps/$_pkgname.png" "$pkgdir/usr/share/icons/hicolor/${_size}x${_size}/apps/$_pkgname.png"
done
+ # Add an extra desktop file to run Ferdium with Wayland
+ cat << EOF > "$pkgdir/usr/share/applications/$_pkgname-wayland.desktop"
+[Desktop Entry]
+Name=${_pkgname^} - Wayland
+Exec=/usr/bin/$_pkgname --enable-features=WaylandWindowDecorations --ozone-platform-hint=wayland %U
+Terminal=falseparu
+Type=Application
+Icon=ferdium
+StartupWMClass=Ferdium
+Comment=Ferdium is your messaging app / former heir to the throne of Austria-Hungary and combines chat & messaging services into one application. Ferdium currently supports Slack, WhatsApp, Gmail, Facebook Messenger, Telegram, Google Hangouts, GroupMe, Skype and many more. You can download Ferdium for free for Mac, Windows, and Linux.
+MimeType=x-scheme-handler/ferdium;
+Categories=Network;InstantMessaging;
+EOF
+
install -dm755 "$pkgdir/usr/share/licenses/$pkgname/"
for _license in 'LICENSE.electron.txt' 'LICENSES.chromium.html'; do
ln -sf "/opt/$pkgname/$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"