summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2024-04-25 20:01:26 +0200
committerKokaKiwi2024-04-25 20:01:26 +0200
commit2f16a424f8dee818c61966af999116645bbefe6b (patch)
tree37c49671c82126a8f54f2a8d03b00eb1cefd7ed1
parentc10b0145dd00497a6807f3cd8992df08e38cf3c4 (diff)
downloadaur-2f16a424f8dee818c61966af999116645bbefe6b.tar.gz
upgpkg: ferdium-electron 6.7.3-1
upstream release Also simplify build and use archives instead of git repositories
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a96192fc71cf..f8235c7f04c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ferdium-electron
pkgdesc = A messaging browser that allows you to combine your favorite messaging services into one application (git build from latest release) - System-wide Electron edition
- pkgver = 6.7.2
+ pkgver = 6.7.3
pkgrel = 1
url = https://ferdium.org/
arch = x86_64
@@ -14,14 +14,14 @@ pkgbase = ferdium-electron
makedepends = asar
makedepends = pnpm
makedepends = nodejs
- depends = electron29
+ depends = electron30
provides = ferdium
conflicts = ferdium
- source = ferdium-electron::git+https://github.com/ferdium/ferdium-app#tag=v6.7.2
- source = ferdium-recipes::git+https://github.com/ferdium/ferdium-recipes.git#branch=main
+ source = ferdium-electron-6.7.3.tar.gz::https://github.com/ferdium/ferdium-app/archive/v6.7.3.tar.gz
+ source = ferdium-recipes-6.7.3.tar.gz::https://github.com/ferdium/ferdium-recipes/archive/7ab6497fbd7bc64c3f2b17b587d273c9bbd155c8.tar.gz
source = ferdium.desktop
- sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = fda8e2683b10c4c2b13eab3f2de79c5357df0d0eb7f639bb4e5889c979327fcb
+ sha256sums = 328d5882238c7fb12db7fc37c6e8d9ee97575d30baa9e6c57fad574f0f29a015
sha256sums = d6e129220ed947cb5fa205211dabc6311a3d9c92434b6bc8deb2fae802c0b0d0
pkgname = ferdium-electron
diff --git a/PKGBUILD b/PKGBUILD
index 84de4ee1996c..7592e30dbc71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Cedric Roijakkers <cedric [the at sign goes here] roijakkers [the dot sign goes here] be>.
# Inspired from the PKGBUILD for ferdi-git.
-_electron='electron29'
+_electron='electron30'
+_recipes_commit='7ab6497fbd7bc64c3f2b17b587d273c9bbd155c8'
pkgname="ferdium-electron"
-pkgver=6.7.2
+pkgver=6.7.3
pkgrel=1
pkgdesc='A messaging browser that allows you to combine your favorite messaging services into one application (git build from latest release) - System-wide Electron edition'
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -16,19 +17,17 @@ makedepends=('git' 'python' 'jq' 'asar'
'nodejs')
provides=('ferdium')
conflicts=('ferdium')
-source=("$pkgname::git+https://github.com/ferdium/ferdium-app#tag=v$pkgver"
- 'ferdium-recipes::git+https://github.com/ferdium/ferdium-recipes.git#branch=main'
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ferdium/ferdium-app/archive/v$pkgver.tar.gz"
+ "ferdium-recipes-$pkgver.tar.gz::https://github.com/ferdium/ferdium-recipes/archive/$_recipes_commit.tar.gz"
ferdium.desktop)
-sha256sums=('SKIP'
- 'SKIP'
+sha256sums=('fda8e2683b10c4c2b13eab3f2de79c5357df0d0eb7f639bb4e5889c979327fcb'
+ '328d5882238c7fb12db7fc37c6e8d9ee97575d30baa9e6c57fad574f0f29a015'
'd6e129220ed947cb5fa205211dabc6311a3d9c92434b6bc8deb2fae802c0b0d0')
prepare() {
- cd "$pkgname"
+ cd "ferdium-app-$pkgver"
- git submodule init
- git config submodule.recipes.url "$srcdir/ferdium-recipes"
- git -c protocol.file.allow=always submodule update
+ cp -Tr "$srcdir/ferdium-recipes-$_recipes_commit" recipes
local node_ver=$(node -v | sed -e 's/^v//')
local pnpm_ver=$(pnpm -v)
@@ -49,16 +48,15 @@ prepare() {
}
build() {
- cd "$pkgname"
+ cd "ferdium-app-$pkgver"
export CI=true
- pnpm install --no-frozen-lockfile
- pnpm run prepare-code || true
+ pnpm install --no-frozen-lockfile --ignore-script
cd "recipes"
- pnpm install --no-frozen-lockfile
+ pnpm install --no-frozen-lockfile --ignore-script
pnpm run package
cd ..
@@ -70,7 +68,7 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "ferdium-app-$pkgver"
install -dm0755 "$pkgdir/usr/bin"
cat > "$pkgdir/usr/bin/ferdium" <<EOF