summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulianne H2023-01-06 21:02:27 +0100
committerJulianne H2023-01-06 21:02:27 +0100
commita224524d432fa62f31740cec1a3e2fafd1c34e11 (patch)
treea6e777ee291a17a8afa48e2744b4641beda2aea6
parent68f80106988b4eeceb46338f75108993a6b8f149 (diff)
downloadaur-a224524d432fa62f31740cec1a3e2fafd1c34e11.tar.gz
Update: 6.2.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05a4c42aaf97..d3d9d8aa38c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ferdium-electron
pkgdesc = A messaging browser that allows you to combine your favorite messaging services into one application (git build from latest release) - System-wide Electron edition
- pkgver = 6.2.2
+ pkgver = 6.2.3
pkgrel = 1
url = https://ferdium.org/
arch = x86_64
@@ -11,14 +11,13 @@ pkgbase = ferdium-electron
makedepends = git
makedepends = python
makedepends = pnpm
- makedepends = npm
makedepends = jq
makedepends = asar
- makedepends = nodejs-lts-gallium
- depends = electron20
+ makedepends = nodejs
+ depends = electron21
provides = ferdium
conflicts = ferdium
- source = ferdium-electron::git+https://github.com/ferdium/ferdium-app#tag=v6.2.2
+ source = ferdium-electron::git+https://github.com/ferdium/ferdium-app#tag=v6.2.3
source = ferdium.desktop
sha512sums = SKIP
sha512sums = e227a9c1cd3bbf2014be0897e05a809be6c0bf185351b6a8c97451af5c6a267283dfaea24bad9e6e300ed4ed91502658787ccba87a6c71f84385c3875c418189
diff --git a/PKGBUILD b/PKGBUILD
index 5f1cece2c379..01ca7c81565a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Cedric Roijakkers <cedric [the at sign goes here] roijakkers [the dot sign goes here] be>.
# Inspired from the PKGBUILD for ferdi-git.
-_electron='electron20'
+_electron='electron21'
pkgname="ferdium-electron"
-pkgver=6.2.2
+pkgver=6.2.3
pkgrel=1
pkgdesc='A messaging browser that allows you to combine your favorite messaging services into one application (git build from latest release) - System-wide Electron edition'
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
url="https://ferdium.org/"
license=('Apache')
depends=("$_electron")
-makedepends=('git' 'python' 'pnpm' 'npm' 'jq' 'asar' 'nodejs-lts-gallium')
+makedepends=('git' 'python' 'pnpm' 'jq' 'asar' 'nodejs')
provides=('ferdium')
conflicts=('ferdium')
source=("$pkgname::git+https://github.com/ferdium/ferdium-app#tag=v$pkgver"
@@ -26,9 +26,8 @@ prepare() {
local node_ver=$(node -v | sed -e 's/^v//')
local pnpm_ver=$(pnpm -v)
- local npm_ver=$(npm -v)
- local jq_expr=".engines.node = \"$node_ver\" | .engines.npm = \"$npm_ver\" | .engines.pnpm = \"$pnpm_ver\""
+ local jq_expr=".engines.node = \"$node_ver\" | .engines.pnpm = \"$pnpm_ver\""
jq "$jq_expr" package.json > package.tmp.json
mv package.tmp.json package.json
@@ -37,7 +36,7 @@ prepare() {
mv package.tmp.json recipes/package.json
# Specify path for autostart file
- sed -i -e "s#^const executablePath =.*#const executablePath = '/usr/bin/ferdium';#g" src/stores/AppStore.ts
+ sed -i -e "s#path: executablePath,#path: '/usr/bin/ferdium',#g" src/stores/AppStore.ts
# Set noUnusedLocals to false to avoid compilation error in AppStore.ts
sed -i -e 's#"noUnusedLocals": true#"noUnusedLocals": false#g' tsconfig.json
}
@@ -47,8 +46,8 @@ build() {
export CI=true
- npm install || true
- npm run prepare-code || true
+ pnpm install || true
+ pnpm run prepare-code || true
cd "recipes"
@@ -57,7 +56,7 @@ build() {
cd ..
- NODE_ENV=production npm run build -- \
+ NODE_ENV=production pnpm run build \
--linux --x64 --dir \
-c.electronDist="/usr/lib/$_electron" \
-c.electronVersion="$(cat "/usr/lib/$_electron/version" | sed -e 's/^v//')"