summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Roijakkers2024-06-24 10:19:51 +0200
committerCedric Roijakkers2024-06-24 10:19:51 +0200
commite0bb5e2a6c9f49e3d21919bac267887c6f6773d7 (patch)
tree17578e72eaf389e2f51060ddd3c33e5f1cd3191a
parentb47c30797e1ade01078400b1dff300b4eb6ab5a8 (diff)
downloadaur-e0bb5e2a6c9f49e3d21919bac267887c6f6773d7.tar.gz
Updated electron to v31 and removed Wayland launcher file as this should be done using an environment variable.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 3 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba1d33255e14..48415ec9d2b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -23,7 +23,7 @@ pkgbase = ferdium-nightly-bin
depends = libxslt
depends = minizip
depends = re2
- depends = electron30
+ depends = electron31
provides = ferdium
conflicts = ferdium
conflicts = ferdium-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0eadf52ccfb5..e4835bc7dff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_pkgname='ferdium'
pkgname="$_pkgname-nightly-bin"
-_electron='electron30'
-_electronpackage='electron30'
+_electron='electron31'
+_electronpackage='electron31'
pkgverorg='6.7.5-nightly.16'
pkgver='6.7.5.nightly.16'
pkgrel='1'
@@ -66,21 +66,6 @@ EOF
for _size in 16 24 32 48 64 96 128 256 512 1024; do
install -Dm644 "usr/share/icons/hicolor/${_size}x${_size}/apps/$_pkgname.png" "$pkgdir/usr/share/icons/hicolor/${_size}x${_size}/apps/$_pkgname.png"
done
-
- # Add an extra desktop file to run Ferdium with Wayland
- cat << EOF > "$pkgdir/usr/share/applications/$_pkgname-wayland.desktop"
-[Desktop Entry]
-Name=${_pkgname^} - Wayland
-Exec=/usr/bin/$_pkgname --enable-features=WaylandWindowDecorations --ozone-platform-hint=wayland %U
-Terminal=false
-Type=Application
-Icon=ferdium
-StartupWMClass=Ferdium
-Comment=Ferdium is your messaging app / former heir to the throne of Austria-Hungary and combines chat & messaging services into one application. Ferdium currently supports Slack, WhatsApp, Gmail, Facebook Messenger, Telegram, Google Hangouts, GroupMe, Skype and many more. You can download Ferdium for free for Mac, Windows, and Linux.
-MimeType=x-scheme-handler/ferdium;
-Categories=Network;InstantMessaging;
-EOF
-
install -dm755 "$pkgdir/usr/share/licenses/$pkgname/"
for _license in 'LICENSE.electron.txt' 'LICENSES.chromium.html'; do
ln -sf "/opt/$pkgname/$_license" "$pkgdir/usr/share/licenses/$pkgname/$_license"