summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyleUltimate2022-10-10 10:52:24 +0800
committerKyleUltimate2022-10-10 10:52:24 +0800
commitcd8bb1362411277dea5698a93742f9d1d5f2b75c (patch)
tree7b16d20b1e582b3d27d174214165b54a1902d9cd
parente3bc8b2c3252d9dc0b69d5c07a1ac71256937216 (diff)
downloadaur-cd8bb1362411277dea5698a93742f9d1d5f2b75c.tar.gz
feat: add support for `aarch64`
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8690cbe4c22f..91524c1372e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,13 +4,16 @@ pkgbase = ferium-bin
pkgrel = 1
url = https://github.com/gorilla-devs/ferium
arch = x86_64
+ arch = aarch64
license = MPL2
depends = bzip2
provides = ferium
conflicts = ferium-gui-bin
conflicts = ferium-git
conflicts = ferium-gui-git
- source = ferium-4.2.0-1.zip::https://github.com/gorilla-devs/ferium/releases/download/v4.2.0/ferium-linux-nogui.zip
- sha256sums = 151d76a917c012aee9b8e8fa47170974903f6868bdb500598167fe082692dd73
+ source_x86_64 = ferium-4.2.0-1.x86_64.zip::https://github.com/gorilla-devs/ferium/releases/download/v4.2.0/ferium-linux-nogui.zip
+ sha256sums_x86_64 = 151d76a917c012aee9b8e8fa47170974903f6868bdb500598167fe082692dd73
+ source_aarch64 = ferium-4.2.0-1.aarch64.zip::https://github.com/gorilla-devs/ferium/releases/download/v4.2.0/ferium-linux-arm64-nogui.zip
+ sha256sums_aarch64 = c8644f0a1e95e4d7e0924dfa6f32752d6d48f5d1b65905dfdf33cce7cbbbff2a
pkgname = ferium-bin
diff --git a/PKGBUILD b/PKGBUILD
index c570d6fab5e6..5cc2287092a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,16 @@ _pkgname=ferium
pkgver=4.2.0
pkgrel=1
pkgdesc="Fast and multi-source CLI program for managing Minecraft mods and modpacks from Modrinth, CurseForge, and Github Releases"
-arch=("x86_64")
+arch=("x86_64" "aarch64")
depends=("bzip2")
provides=("ferium")
conflicts=("ferium-gui-bin" "ferium-git" "ferium-gui-git")
url="https://github.com/gorilla-devs/ferium"
license=('MPL2')
-source=("$_pkgname-$pkgver-$pkgrel.zip::https://github.com/gorilla-devs/ferium/releases/download/v$pkgver/ferium-linux-nogui.zip")
-sha256sums=('151d76a917c012aee9b8e8fa47170974903f6868bdb500598167fe082692dd73')
+source_x86_64=("$_pkgname-$pkgver-$pkgrel.x86_64.zip::https://github.com/gorilla-devs/ferium/releases/download/v$pkgver/ferium-linux-nogui.zip")
+source_aarch64=("$_pkgname-$pkgver-$pkgrel.aarch64.zip::https://github.com/gorilla-devs/ferium/releases/download/v$pkgver/ferium-linux-arm64-nogui.zip")
+sha256sums_x86_64=('151d76a917c012aee9b8e8fa47170974903f6868bdb500598167fe082692dd73')
+sha256sums_aarch64=('c8644f0a1e95e4d7e0924dfa6f32752d6d48f5d1b65905dfdf33cce7cbbbff2a')
package() {
cd "$srcdir"